# CVE-2026-39861: Claude Code: Sandbox Escape via Symlink Following Allows Arbitrary File Write Outside Workspace

> Attackers can escape the sandbox and write arbitrary files outside the workspace via symlink following, potentially leading to code execution.

- **Severity:** High 7.7 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 21 Apr 2026
- **Updated:** 21 Apr 2026
- **Also known as:** GHSA-vp62-r36r-9xqp

## What is CVE-2026-39861?

CVE-2026-39861 is a high-severity path traversal vulnerability in anthropics claude-code, published on 21 Apr 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Claude Code is an agentic coding tool. Prior to version 2.1.64, Claude Code's sandbox did not prevent sandboxed processes from creating symlinks pointing to locations outside the workspace. When Claude Code subsequently wrote to a path within such a symlink, its unsandboxed process followed the symlink and wrote to the target location outside the workspace without prompting the user for confirmation. This allowed a sandbox escape where neither the sandboxed command nor the unsandboxed app could independently write outside the workspace, but their combination could write to arbitrary locations, potentially leading to code execution outside the sandbox. Reliably exploiting this required the ability to add untrusted content into a Claude Code context window to trigger sandboxed code execution via prompt injection. Users on standard Claude Code auto-update have received this fix automatically. Users performing manual updates are advised to update to version 2.1.64 or later.

Weakness: CWE-61 (UNIX Symbolic Link (Symlink) Following), CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-39861?

2 open source packages ship an affected version, including @anthropic-ai/claude-code. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@anthropic-ai/claude-code` | npm | All versions | 2.1.64 |
| `@anthropic-ai/claude-code` | npm | All versions | 2.1.64 |

Products: Anthropic Claude Code.

## How do I fix CVE-2026-39861?

Upgrade @anthropic-ai/claude-code to 2.1.64 or later.

## Is CVE-2026-39861 being exploited?

There is no known exploitation of CVE-2026-39861 in the wild and no public exploit code.

## Other vulnerabilities in anthropics claude-code

- [CVE-2025-66032](https://insights.sbomify.com/CVE-2025-66032/): Claude Code Command Validation Bypass Allows Arbitrary Code Execution (high 8.7)
- [CVE-2025-64755](https://insights.sbomify.com/CVE-2025-64755/): @anthropic-ai/claude-code has Sed Command Validation Bypass that Allows Arbitrary File Writes (high 8.7)
- [CVE-2025-59536](https://insights.sbomify.com/CVE-2025-59536/): Claude Code's startup trust dialog could lead to Command Execution attack (high 8.7)
- [CVE-2025-58764](https://insights.sbomify.com/CVE-2025-58764/): Claude Code rg command had Command Injection that allowed bypass of user approval prompt for command execution (high 8.7)
- [CVE-2025-59041](https://insights.sbomify.com/CVE-2025-59041/): Claude Code vulnerable to arbitrary code execution caused by maliciously configured git email (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-39861 and fix it if it is affected.

What it is: CVE-2026-39861 is a high-severity path traversal vulnerability in anthropics claude-code, published on 21 Apr 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-39861 in the wild and no public exploit code.

Affected packages and fixed versions:
- @anthropic-ai/claude-code (npm): affected all versions; fixed in 2.1.64
- @anthropic-ai/claude-code (npm): affected all versions; fixed in 2.1.64

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-39861/ (Markdown: https://insights.sbomify.com/CVE-2026-39861/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-39861
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-39861
- OSV: https://osv.dev/vulnerability/CVE-2026-39861

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-39861/
Summaries are generated and may contain mistakes; the official description above is the record.
