CVE-2026-39863 Kamailio Core: TCP Data Processing Vulnerability

High 7.5 Published Updated

Remote attackers can crash Kamailio SIP servers via crafted TCP packets due to out-of-bounds memory access, requiring an upgrade to patched versions.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-39863?

CVE-2026-39863 is a high-severity memory corruption vulnerability in kamailio, published on 8 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Kamailio is an open source implementation of a SIP Signaling Server. Prior to 6.1.1, 6.0.6, and 5.8.8, an out-of-bounds access in the core of Kamailio (formerly OpenSER and SER) allows remote attackers to cause a denial of service (process crash) via a specially crafted data packet sent over TCP. The issue impacts Kamailio instances having TCP or TLS listeners. This vulnerability is fixed in 5.1.1, 6.0.6, and 5.8.8.

Weakness: CWE-119

Which versions are affected by CVE-2026-39863?

It affects 1 product.

Products include Kamailio Kamailio.

How do I fix CVE-2026-39863?

Upgrade to a fixed version.

Upgrade to the fixed version. Memory-safe languages, compiler hardening and fuzzing prevent most new cases. More about Memory corruption.

Is CVE-2026-39863 being exploited?

There is no known exploitation of CVE-2026-39863 in the wild and no public exploit code.

Sources

Also known as ALPINE-CVE-2026-39863, DEBIAN-CVE-2026-39863, GHSA-2wj4-f825-2h2f, UBUNTU-CVE-2026-39863.

Is CVE-2026-39863 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free