# CVE-2026-39864: Kamailio Auth: Processing Vulnerability For Additional Authenticated User Identity Checks

> Remote attackers can crash the Kamailio SIP server via crafted packets when specific authentication checks are enabled without a database backend.

- **Severity:** Medium 4.4 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Apr 2026
- **Updated:** 8 Apr 2026
- **Also known as:** DEBIAN-CVE-2026-39864, GHSA-6m86-m342-g48m, UBUNTU-CVE-2026-39864

## What is CVE-2026-39864?

CVE-2026-39864 is a medium-severity denial of service vulnerability in kamailio, published on 8 Apr 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Kamailio is an open source implementation of a SIP Signaling Server. Prior to 6.0.5 and 5.8.7, an out-of-bounds read in the auth module of Kamailio (formerly OpenSER and SER) allows remote attackers to cause a denial of service (process crash) via a specially crafted SIP packet if a successful user authentication without a database backend is followed by additional user identity checks. This vulnerability is fixed in 6.0.5 and 5.8.7.

Weakness: CWE-125 (Out-of-bounds Read)

## Which versions are affected by CVE-2026-39864?

It affects 1 product.


Products: Kamailio Kamailio.

## How do I fix CVE-2026-39864?

Upgrade to a fixed version.

## Is CVE-2026-39864 being exploited?

There is no known exploitation of CVE-2026-39864 in the wild and no public exploit code.

## Other vulnerabilities in kamailio

- [CVE-2020-27507](https://insights.sbomify.com/CVE-2020-27507/): Memory corruption in n/a (critical 9.8)
- [CVE-2013-7426](https://insights.sbomify.com/CVE-2013-7426/): File upload in n/a (critical 9.8)
- [CVE-2015-1590](https://insights.sbomify.com/CVE-2015-1590/): Path traversal in n/a (high 7.8)
- [CVE-2015-1591](https://insights.sbomify.com/CVE-2015-1591/): Privilege escalation in n/a (high 7.8)
- [CVE-2026-52022](https://insights.sbomify.com/CVE-2026-52022/): Denial of service in n/a (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-39864 and fix it if it is affected.

What it is: CVE-2026-39864 is a medium-severity denial of service vulnerability in kamailio, published on 8 Apr 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-39864 in the wild and no public exploit code.

Affected product: kamailio. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-39864/ (Markdown: https://insights.sbomify.com/CVE-2026-39864/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-39864
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-39864
- OSV: https://osv.dev/vulnerability/CVE-2026-39864

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-39864/
Summaries are generated and may contain mistakes; the official description above is the record.
