CVE-2026-39884 MCP Server Kubernetes has Argument Injection in its port_forward tool via space-splitting

High 8.3 Published Updated

Attackers can inject arbitrary kubectl flags via space-splitting in the port_forward tool, enabling network exposure or cross-namespace access.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-39884?

CVE-2026-39884 is a high-severity command injection vulnerability in Flux159 mcp-server-kubernetes, published on 14 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

mcp-server-kubernetes is a Model Context Protocol server for Kubernetes cluster management. Versions 3.4.0 and prior contain an argument injection vulnerability in the port_forward tool in src/tools/port_forward.ts, where a kubectl command is constructed via string concatenation with user-controlled input and then naively split on spaces before being passed to spawn(). Unlike all other tools in the codebase which correctly use array-based argument passing with execFileSync(), port_forward treats every space in user-controlled fields (namespace, resourceType, resourceName, localPort, targetPort) as an argument boundary, allowing an attacker to inject arbitrary kubectl flags. This enables exposure of internal Kubernetes services to the network by injecting --address=0.0.0.0, cross-namespace targeting by injecting additional -n flags, and indirect exploitation via prompt injection against AI agents connected to the MCP server. This issue has been fixed in version 3.5.0.

Weakness: CWE-88

Which versions are affected by CVE-2026-39884?

2 open source packages ship an affected version, including mcp-server-kubernetes. It affects 1 product.

PackageAffectedFixed in
mcp-server-kubernetes npmAll versions3.5.0
mcp-server-kubernetes npmAll versions3.5.0

Products include Suyogs Mcp-Server-Kubernetes.

How do I fix CVE-2026-39884?

Upgrade mcp-server-kubernetes to 3.5.0 or later.

Upgrade, and pass arguments to programs as a list instead of through a shell. More about Command injection.

Is CVE-2026-39884 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-39884 exists.

Sources

Also known as GHSA-4xqg-gf5c-ghwq.

Is CVE-2026-39884 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free