# CVE-2026-39885: FrontMCP Affected by SSRF via $ref Dereferencing in Untrusted OpenAPI Specifications

> Attackers can trigger SSRF and local file reads by providing malicious OpenAPI specifications to the FrontMCP library.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Apr 2026
- **Updated:** 9 Apr 2026
- **Also known as:** GHSA-v6ph-xcq9-qxxj

## What is CVE-2026-39885?

CVE-2026-39885 is a high-severity server-side request forgery vulnerability in @frontmcp adapters, published on 8 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

FrontMCP is a TypeScript-first framework for the Model Context Protocol (MCP). Prior to 2.3.0, the mcp-from-openapi library uses @apidevtools/json-schema-ref-parser to dereference $ref pointers in OpenAPI specifications without configuring any URL restrictions or custom resolvers. A malicious OpenAPI specification containing $ref values pointing to internal network addresses, cloud metadata endpoints, or local files will cause the library to fetch those resources during the initialize() call. This enables Server-Side Request Forgery (SSRF) and local file read attacks when processing untrusted OpenAPI specifications. This vulnerability is fixed in 2.3.0.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-39885?

6 open source packages ship an affected version, including @frontmcp/adapters, @frontmcp/sdk and mcp-from-openapi. It affects 4 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@frontmcp/adapters` | npm | All versions | 1.0.4 |
| `@frontmcp/adapters` | npm | All versions | 1.0.4 |
| `@frontmcp/sdk` | npm | All versions | 1.0.4 |
| `@frontmcp/sdk` | npm | All versions | 1.0.4 |
| `mcp-from-openapi` | npm | All versions | 2.3.0 |
| `mcp-from-openapi` | npm | All versions | 2.3.0 |

Products: Agentfront \@Frontmcp\/Adapters, Agentfront \@Frontmcp\/Sdk, Agentfront Frontmcp, Frontmcp Mcp-From-Openapi.

## How do I fix CVE-2026-39885?

Upgrade @frontmcp/adapters to 1.0.4 or later.

## Is CVE-2026-39885 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-39885 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-39885 and fix it if it is affected.

What it is: CVE-2026-39885 is a high-severity server-side request forgery vulnerability in @frontmcp adapters, published on 8 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-39885 exists.

Affected packages and fixed versions:
- @frontmcp/adapters (npm): affected all versions; fixed in 1.0.4
- @frontmcp/adapters (npm): affected all versions; fixed in 1.0.4
- @frontmcp/sdk (npm): affected all versions; fixed in 1.0.4
- @frontmcp/sdk (npm): affected all versions; fixed in 1.0.4
- mcp-from-openapi (npm): affected all versions; fixed in 2.3.0
- mcp-from-openapi (npm): affected all versions; fixed in 2.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-39885/ (Markdown: https://insights.sbomify.com/CVE-2026-39885/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-39885
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-39885
- OSV: https://osv.dev/vulnerability/CVE-2026-39885

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-39885/
Summaries are generated and may contain mistakes; the official description above is the record.
