# CVE-2026-39888: PraisonAIAgents has a sandbox escape via exception frame traversal in `execute_code` (subprocess mode)

> Attackers can escape the sandbox and execute arbitrary code by traversing exception frames to access restricted builtins in PraisonAIAgents.

- **Severity:** Critical 10.0 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Apr 2026
- **Updated:** 9 Apr 2026
- **Also known as:** GHSA-qf73-2hrx-xprp, PYSEC-2026-486

## What is CVE-2026-39888?

CVE-2026-39888 is a critical code injection vulnerability in MervinPraison praisonaiagents, published on 8 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

PraisonAI is a multi-agent teams system. Prior to 1.5.115, execute_code() in praisonaiagents.tools.python_tools defaults to sandbox_mode="sandbox", which runs user code in a subprocess wrapped with a restricted __builtins__ dict and an AST-based blocklist. The AST blocklist embedded inside the subprocess wrapper (blocked_attrs of python_tools.py) contains only 11 attribute names — a strict subset of the 30+ names blocked in the direct-execution path. The four attributes that form a frame-traversal chain out of the sandbox are all absent from the subprocess list (__traceback__, tb_frame, f_back, and f_builtins). Chaining these attributes through a caught exception exposes the real Python builtins dict of the subprocess wrapper frame, from which exec can be retrieved and called under a non-blocked variable name — bypassing every remaining security layer. This vulnerability is fixed in 1.5.115.

Weakness: CWE-693 (Protection Mechanism Failure), CWE-657 (Violation of Secure Design Principles)

## Which versions are affected by CVE-2026-39888?

3 open source packages ship an affected version, including praisonaiagents. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `praisonaiagents` | PyPI | All versions | 1.5.115 |
| `praisonaiagents` | PyPI | All versions | 1.5.115 |
| `praisonaiagents` | PyPI | All versions | 1.5.115 |

Products: Praison Praisonai.

## How do I fix CVE-2026-39888?

Upgrade praisonaiagents to 1.5.115 or later.

## Is CVE-2026-39888 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-39888 exists.

## Other vulnerabilities in MervinPraison praisonaiagents

- [CVE-2026-41497](https://insights.sbomify.com/CVE-2026-41497/): Incomplete fix for CVE-2026-34935: Command Injection in MervinPraison/PraisonAI (critical 9.8)
- [CVE-2026-40288](https://insights.sbomify.com/CVE-2026-40288/): PraisonAI: Critical RCE via `type: job` workflow YAML (critical 9.8)
- [CVE-2026-39890](https://insights.sbomify.com/CVE-2026-39890/): PraisonAI Affected by Remote Code Execution via YAML Deserialization in Agent Definition Loading (critical 9.8)
- [CVE-2026-34934](https://insights.sbomify.com/CVE-2026-34934/): PraisonAI: Second-Order SQL Injection in `get_all_user_threads` (critical 9.8)
- [CVE-2026-34935](https://insights.sbomify.com/CVE-2026-34935/): PraisonAI: OS Command Injection in MCPHandler.parse_mcp_command() (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-39888 and fix it if it is affected.

What it is: CVE-2026-39888 is a critical code injection vulnerability in MervinPraison praisonaiagents, published on 8 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-39888 exists.

Affected packages and fixed versions:
- praisonaiagents (PyPI): affected all versions; fixed in 1.5.115
- praisonaiagents (PyPI): affected all versions; fixed in 1.5.115
- praisonaiagents (PyPI): affected all versions; fixed in 1.5.115

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-39888/ (Markdown: https://insights.sbomify.com/CVE-2026-39888/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-39888
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-39888
- OSV: https://osv.dev/vulnerability/CVE-2026-39888

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-39888/
Summaries are generated and may contain mistakes; the official description above is the record.
