{"answers":{"affected":"3 open source packages ship an affected version, including cryptography. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-39892 in the wild and no public exploit code.","fix":"Upgrade cryptography to 46.0.7 or later.","what":"CVE-2026-39892 is a medium-severity memory corruption vulnerability in pyca cryptography, published on 8 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-39892 and fix it if it is affected.\n\nWhat it is: CVE-2026-39892 is a medium-severity memory corruption vulnerability in pyca cryptography, published on 8 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-39892 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- cryptography (PyPI): affected from 45.0.0; fixed in 46.0.7\n- cryptography (PyPI): affected from 45.0.0; fixed in 46.0.7\n- cryptography (PyPI): affected from 45.0.0; fixed in 46.0.7\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-39892/ (Markdown: https://insights.sbomify.com/CVE-2026-39892/index.md)","id":"CVE-2026-39892","markdown":"https://insights.sbomify.com/CVE-2026-39892/index.md","name":"CVE-2026-39892","record":{"aliases":["ALPINE-CVE-2026-39892","BELL-CVE-2026-39892","CLEANSTART-2026-HA56208","CLEANSTART-2026-TY96751","CLSA-2026-1778028237","DEBIAN-CVE-2026-39892","ECHO-0a60-183d-a61b","GHSA-p423-j2cm-9vmq","MINI-48mw-84m4-mj38","MINI-49c3-26hx-838f","MINI-85qm-27f2-fx26","MINI-89rm-vhw7-9rgw","MINI-gx47-x28g-h7gw","MINI-jr38-pqp9-5c6r","MINI-p9f2-5vrj-h6xg","MINI-pvhg-wrh8-6c9m","MINI-qv8f-2wcf-75cg","MINI-rw4r-jmx7-9f66","MINI-v49p-r2xv-hc22","MINI-wm23-4f6g-h5pm","MINI-wxcw-5g46-424c","PYSEC-2026-36","ROOT-APP-PYPI-CVE-2026-39892","openSUSE-SU-2026:10535-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Python cryptography library","requires_auth":"none","summary":"Attackers can trigger buffer overflows in the Python cryptography library by passing non-contiguous buffers to APIs, potentially leading to code execution or crashes.","user_interaction":"not_required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"cryptography","vendor":"cryptography.io"}],"cvss":{"score":6.9,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-131","name":"Incorrect Calculation of Buffer Size"},{"id":"CWE-119","name":"Improper Restriction of Operations within the Bounds of a Memory Buffer"}],"description":"cryptography is a package designed to expose cryptographic primitives and recipes to Python developers. From 45.0.0 to before 46.0.7, if a non-contiguous buffer was passed to APIs which accepted Python buffers (e.g. Hash.update()), this could lead to buffer overflows. This vulnerability is fixed in 46.0.7.","ecosystems":["PyPI","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"cryptography has a buffer overflow if non-contiguous buffers were passed to APIs","id":"CVE-2026-39892","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"memory_corruption","year":"2026"},"n_packages":4,"n_references":1,"next":{"headline":"Cacti: Pre-authentication SQL injection via rfilter RLIKE clause in graph_view.php","id":"CVE-2026-39893"},"packages":[{"ecosystem":"PyPI","fixed":["46.0.7"],"introduced":["45.0.0"],"last_affected":[],"package":"cryptography","purl":null,"source":"GHSA-p423-j2cm-9vmq"},{"ecosystem":"PyPI","fixed":["46.0.7"],"introduced":["45.0.0"],"last_affected":[],"package":"cryptography","purl":"pkg:pypi/cryptography","source":"GHSA-p423-j2cm-9vmq"},{"ecosystem":"PyPI","fixed":["46.0.7"],"introduced":["45.0.0"],"last_affected":[],"package":"cryptography","purl":"pkg:pypi/cryptography","source":"PYSEC-2026-36"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["46.0.7-1.1"],"introduced":["0"],"last_affected":[],"package":"python-cryptography","purl":"pkg:rpm/opensuse/python-cryptography\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2026:10535-1"}],"prev":{"headline":"PraisonAI has a Template Injection in Agent Tool Definitions","id":"CVE-2026-39891"},"products":["cryptography"],"published":"2026-04-08","related":[{"cvss_score":9.1,"headline":"PyCA Cryptography symmetrically encrypting large values can lead to integer overflow","id":"CVE-2020-36242","kev_date_added":null,"published":"2021-02-07"},{"cvss_score":8.2,"headline":"cryptography Subgroup Attack Due to Missing Subgroup Validation for SECT Curves","id":"CVE-2026-26007","kev_date_added":null,"published":"2026-02-10"},{"cvss_score":7.5,"headline":"cryptography NULL pointer dereference with pkcs12.serialize_key_and_certificates when called with a non-matching certificate and private key and an hmac_hash override","id":"CVE-2024-26130","kev_date_added":null,"published":"2024-02-21"},{"cvss_score":7.5,"headline":"cryptography mishandles SSH certificates","id":"CVE-2023-38325","kev_date_added":null,"published":"2023-07-14"},{"cvss_score":5.9,"headline":"cryptography vulnerable to NULL-dereference when loading PKCS7 certificates","id":"CVE-2023-49083","kev_date_added":null,"published":"2023-11-29"},{"cvss_score":5.9,"headline":"RSA decryption vulnerable to Bleichenbacher timing vulnerability","id":"CVE-2020-25659","kev_date_added":null,"published":"2021-01-11"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-09-10","vendors":["pyca"]},"summary":"Attackers can trigger buffer overflows in the Python cryptography library by passing non-contiguous buffers to APIs, potentially leading to code execution or crashes.","url":"https://insights.sbomify.com/CVE-2026-39892/"}