{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-39894 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2026-39894 is a low-severity vulnerability in Cacti Cacti, published on 24 Jun 2026. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-39894 and fix it if it is affected.\n\nWhat it is: CVE-2026-39894 is a low-severity vulnerability in Cacti Cacti, published on 24 Jun 2026. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-39894 in the wild and no public exploit code.\n\nAffected product: Cacti Cacti. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-39894/ (Markdown: https://insights.sbomify.com/CVE-2026-39894/index.md)","id":"CVE-2026-39894","markdown":"https://insights.sbomify.com/CVE-2026-39894/index.md","name":"CVE-2026-39894","record":{"aliases":["DEBIAN-CVE-2026-39894","GHSA-23g4-vf2j-94w4","UBUNTU-CVE-2026-39894"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_modify"],"network_reachable":"adjacent_or_local","non_default_config":true,"product_category":"Network monitoring tool","requires_auth":"none","summary":"Cacti corrupts RRDtool metrics if the server locale uses comma decimal separators, requiring a locale misconfiguration to trigger data integrity issues.","user_interaction":"not_required","vuln_class":"misconfiguration"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"cacti","vendor":"cacti"}],"cvss":{"score":2.9,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-474","name":"Use of Function with Inconsistent Implementations"}],"description":"Cacti is an open source performance and fault management framework. In versions 1.2.30 and below, the locale-dependent decimal formatting in rrdtool_function_update() can corrupt RRDtool metric values. The rrdtool_function_update() function checks metric values with is_numeric() and concatenates them into the RRDtool update command via PHP string interpolation. PHP's string cast of floats is locale-sensitive: if LC_NUMERIC uses comma as decimal separator (e.g., de_DE), a value of 1.5 becomes \"1,5\". RRDtool expects . as decimal separator, causing metric data to shift into wrong columns or be silently dropped. No setlocale() reset is present in the update path. This causes a data integrity issue, but is not remotely exploitable; it requires server locale misconfiguration. The issue has been fixed in version 1.2.31.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Cacti: RRDtool metric shift via LC_NUMERIC locale comma decimal formatting","id":"CVE-2026-39894","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"cacti:cacti","products":["cacti:cacti"],"type":"misconfiguration","year":"2026"},"n_packages":0,"n_references":3,"next":{"headline":"Cacti has a Reflected XSS Vulnerability via html_auth_footer","id":"CVE-2026-39897"},"packages":[],"prev":{"headline":"Cacti: Pre-authentication SQL injection via rfilter RLIKE clause in graph_view.php","id":"CVE-2026-39893"},"products":["cacti"],"published":"2026-06-24","related":[{"cvss_score":9.8,"headline":"Cacti Command Injection","id":"CVE-2022-46169","kev_date_added":"2023-02-16","published":"2022-12-05"},{"cvss_score":9.8,"headline":"Cacti: Pre-authentication SQL injection via rfilter RLIKE clause in graph_view.php","id":"CVE-2026-39893","kev_date_added":null,"published":"2026-06-24"},{"cvss_score":9.8,"headline":"Cacti: Unauthenticated RCE on Graph Image","id":"CVE-2026-39938","kev_date_added":null,"published":"2026-06-24"},{"cvss_score":9.8,"headline":"Cacti has Pre-Authentication SQL Injection via unanchored FILTER_VALIDATE_REGEXP in graph_view.php","id":"CVE-2026-39955","kev_date_added":null,"published":"2026-06-24"},{"cvss_score":9.8,"headline":"Unauthenticated SQL Injection in graph_view.php in Cacti","id":"CVE-2023-39361","kev_date_added":null,"published":"2023-09-05"},{"cvss_score":9.8,"headline":"Auth bypass in Cati","id":"CVE-2022-0730","kev_date_added":null,"published":"2022-03-03"},{"cvss_score":9.8,"headline":"Command injection in n/a","id":"CVE-2017-12065","kev_date_added":null,"published":"2017-08-01"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-06-25","vendors":["Cacti"]},"summary":"Cacti corrupts RRDtool metrics if the server locale uses comma decimal separators, requiring a locale misconfiguration to trigger data integrity issues.","url":"https://insights.sbomify.com/CVE-2026-39894/"}