CVE-2026-39897 Cacti has a Reflected XSS Vulnerability via html_auth_footer

Medium 5.3 Published Updated

Attackers can execute arbitrary scripts in victim browsers via reflected XSS in Cacti, potentially leading to session hijacking or data theft.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2026-39897?

CVE-2026-39897 is a medium-severity cross-site scripting vulnerability in Cacti Cacti, published on 24 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

Cacti is an open source performance and fault management framework. Versions 1.2.30 and below contain a Reflected XSS vulnerability in the html_auth_footer. This issue has been fixed in version 1.2.31.

Weakness: CWE-79

Which versions are affected by CVE-2026-39897?

It affects 1 product.

Products include Cacti Cacti.

How do I fix CVE-2026-39897?

Upgrade to a fixed version.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2026-39897 being exploited?

There is no known exploitation of CVE-2026-39897 in the wild and no public exploit code.

All Cacti Cacti vulnerabilities

Sources

Also known as DEBIAN-CVE-2026-39897, GHSA-2j98-xfjq-gw39, UBUNTU-CVE-2026-39897.

Is CVE-2026-39897 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free