{"answers":{"affected":"1 open source package ship an affected version, including geonode. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-39921 in the wild and no public exploit code.","fix":"Upgrade geonode to a fixed version for your release line: 4.4.5 or 5.0.2.","what":"CVE-2026-39921 is a medium-severity server-side request forgery vulnerability in GeoNode, published on 10 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-39921 and fix it if it is affected.\n\nWhat it is: CVE-2026-39921 is a medium-severity server-side request forgery vulnerability in GeoNode, published on 10 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-39921 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- geonode (PyPI): affected from 4.0.0; fixed in 4.4.5, 5.0.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-39921/ (Markdown: https://insights.sbomify.com/CVE-2026-39921/index.md)","id":"CVE-2026-39921","markdown":"https://insights.sbomify.com/CVE-2026-39921/index.md","name":"CVE-2026-39921","record":{"aliases":["GHSA-x87c-g7pw-2xr5","PYSEC-2026-2159"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"GeoNode web application","requires_auth":"low_privilege","summary":"Authenticated users can trigger arbitrary outbound HTTP requests via malicious URLs in document uploads, potentially accessing internal network resources or cloud metadata.","user_interaction":"not_required","vuln_class":"ssrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[{"product":"geonode","vendor":"geosolutionsgroup"}],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:N/SC:L/SI:L/SA:L","version":"4.0"},"cwes":[{"id":"CWE-918","name":"Server-Side Request Forgery"}],"description":"GeoNode versions 4.0 before 4.4.5 and 5.0 before 5.0.2 contain a server-side request forgery vulnerability that allows authenticated users with document upload permissions to trigger arbitrary outbound HTTP requests by providing a malicious URL via the doc_url parameter during document upload. Attackers can supply URLs pointing to internal network targets, loopback addresses, RFC1918 addresses, or cloud metadata services to cause the server to make requests to internal resources without SSRF mitigations such as private IP filtering or redirect validation.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"GeoNode \u003c 4.4.5, 5.0.2 SSRF via Document Upload","id":"CVE-2026-39921","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"ssrf","year":"2026"},"n_packages":1,"n_references":6,"next":{"headline":"GeoNode SSRF via Service Registration","id":"CVE-2026-39922"},"packages":[{"ecosystem":"PyPI","fixed":["4.4.5","5.0.2"],"introduced":["4.0.0","5.0.0"],"last_affected":[],"package":"geonode","purl":"pkg:pypi/geonode","source":"PYSEC-2026-2159"}],"prev":{"headline":"BridgeHead FileStore \u003c 24A Apache Axis2 Default Credentials RCE","id":"CVE-2026-39920"},"products":["GeoNode"],"published":"2026-04-10","related":[{"cvss_score":7.5,"headline":"GeoNode SSRF Bypass to return internal host data","id":"CVE-2023-42439","kev_date_added":null,"published":"2023-09-15"},{"cvss_score":7.5,"headline":"Geonode Server Side Request Forgery vulnerability","id":"CVE-2023-40017","kev_date_added":null,"published":"2023-08-24"},{"cvss_score":7.5,"headline":"Geoserver for GeoNode sensitive information leak","id":"CVE-2023-28442","kev_date_added":null,"published":"2023-03-23"},{"cvss_score":6.5,"headline":"XML External Entity (XXE) injection in GeoServer style upload functionality","id":"CVE-2023-26043","kev_date_added":null,"published":"2023-02-27"},{"cvss_score":6.1,"headline":"GeoNode stored XSS to full account takeover","id":"CVE-2024-27091","kev_date_added":null,"published":"2024-03-27"},{"cvss_score":5.3,"headline":"GeoNode SSRF via Service Registration","id":"CVE-2026-39922","kev_date_added":null,"published":"2026-04-10"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-07-14","vendors":["GeoNode"]},"summary":"Authenticated users can trigger arbitrary outbound HTTP requests via malicious URLs in document uploads, potentially accessing internal network resources or cloud metadata.","url":"https://insights.sbomify.com/CVE-2026-39921/"}