# CVE-2026-39921: GeoNode < 4.4.5, 5.0.2 SSRF via Document Upload

> Authenticated users can trigger arbitrary outbound HTTP requests via malicious URLs in document uploads, potentially accessing internal network resources or cloud metadata.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:N/SC:L/SI:L/SA:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Apr 2026
- **Updated:** 14 Jul 2026
- **Also known as:** GHSA-x87c-g7pw-2xr5, PYSEC-2026-2159

## What is CVE-2026-39921?

CVE-2026-39921 is a medium-severity server-side request forgery vulnerability in GeoNode, published on 10 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

GeoNode versions 4.0 before 4.4.5 and 5.0 before 5.0.2 contain a server-side request forgery vulnerability that allows authenticated users with document upload permissions to trigger arbitrary outbound HTTP requests by providing a malicious URL via the doc_url parameter during document upload. Attackers can supply URLs pointing to internal network targets, loopback addresses, RFC1918 addresses, or cloud metadata services to cause the server to make requests to internal resources without SSRF mitigations such as private IP filtering or redirect validation.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-39921?

1 open source package ship an affected version, including geonode. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `geonode` | PyPI | From 4.0.0 | 4.4.5, 5.0.2 |

Products: Geosolutionsgroup Geonode.

## How do I fix CVE-2026-39921?

Upgrade geonode to a fixed version for your release line: 4.4.5 or 5.0.2.

## Is CVE-2026-39921 being exploited?

There is no known exploitation of CVE-2026-39921 in the wild and no public exploit code.

## Other vulnerabilities in GeoNode

- [CVE-2023-42439](https://insights.sbomify.com/CVE-2023-42439/): GeoNode SSRF Bypass to return internal host data (high 7.5)
- [CVE-2023-40017](https://insights.sbomify.com/CVE-2023-40017/): Geonode Server Side Request Forgery vulnerability (high 7.5)
- [CVE-2023-28442](https://insights.sbomify.com/CVE-2023-28442/): Geoserver for GeoNode sensitive information leak (high 7.5)
- [CVE-2023-26043](https://insights.sbomify.com/CVE-2023-26043/): XML External Entity (XXE) injection in GeoServer style upload functionality (medium 6.5)
- [CVE-2024-27091](https://insights.sbomify.com/CVE-2024-27091/): GeoNode stored XSS to full account takeover (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-39921 and fix it if it is affected.

What it is: CVE-2026-39921 is a medium-severity server-side request forgery vulnerability in GeoNode, published on 10 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-39921 in the wild and no public exploit code.

Affected packages and fixed versions:
- geonode (PyPI): affected from 4.0.0; fixed in 4.4.5, 5.0.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-39921/ (Markdown: https://insights.sbomify.com/CVE-2026-39921/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-39921
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-39921
- OSV: https://osv.dev/vulnerability/CVE-2026-39921

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-39921/
Summaries are generated and may contain mistakes; the official description above is the record.
