# CVE-2026-39946: OpenBao allows SQL Injection in PostgreSQL database secrets engine

> Attackers can inject SQL via schema names in the PostgreSQL secrets engine, potentially executing code or modifying data.

- **Severity:** Medium 4.6 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:N/VC:N/VI:N/VA:N/SC:H/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Apr 2026
- **Updated:** 21 Apr 2026
- **Also known as:** BIT-openbao-2026-39946, GHSA-6vgr-cp5c-ffx3, GO-2026-5192

## What is CVE-2026-39946?

CVE-2026-39946 is a medium-severity SQL injection vulnerability in openbao, published on 21 Apr 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

OpenBao is an open source identity-based secrets management system. Prior to version 2.5.3, when OpenBao revoked privileges on a role in the PostgreSQL database secrets engine, OpenBao failed to use proper database quoting on schema names provided by PostgreSQL. This could lead to role revocation failures, or more rarely, SQL injection as the management user. This vulnerability was original from HashiCorp Vault. The vulnerability is addressed in v2.5.3. As a workaround, audit table schemas and ensure database users cannot create new schemas and grant privileges on them.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2026-39946?

4 open source packages ship an affected version, including github.com/openbao/openbao and openbao. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/openbao/openbao` | Go | All versions | 0.0.0-20260420155735-b596b0882620 |
| `github.com/openbao/openbao` | Go | All versions | 0.0.0-20260420155735-b596b0882620 |
| `github.com/openbao/openbao` | Go | All versions | 0.0.0-20260420155735-b596b0882620 |
| `openbao` | Bitnami | All versions | 2.5.3 |

Products: Openbao Openbao.

## How do I fix CVE-2026-39946?

Upgrade github.com/openbao/openbao to 0.0.0-20260420155735-b596b0882620 or later.

## Is CVE-2026-39946 being exploited?

There is no known exploitation of CVE-2026-39946 in the wild and no public exploit code.

## Other vulnerabilities in openbao

- [CVE-2026-33757](https://insights.sbomify.com/CVE-2026-33757/): OpenBao lacks user confirmation for OIDC direct callback mode (critical 9.6)
- [CVE-2026-33758](https://insights.sbomify.com/CVE-2026-33758/): OpenBao has Reflected XSS in its OIDC authentication error message (critical 9.4)
- [CVE-2025-54997](https://insights.sbomify.com/CVE-2025-54997/): OpenBao: Privileged Operator May Execute Code on the Underlying Host (critical 9.1)
- [CVE-2025-64761](https://insights.sbomify.com/CVE-2025-64761/): OpenBao Privileged Operator Identity Group Root Escalation (high 7.5)
- [CVE-2025-59043](https://insights.sbomify.com/CVE-2025-59043/): OpenBao vulnerable to denial of service via malicious JSON request processing (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-39946 and fix it if it is affected.

What it is: CVE-2026-39946 is a medium-severity SQL injection vulnerability in openbao, published on 21 Apr 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-39946 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/openbao/openbao (Go): affected all versions; fixed in 0.0.0-20260420155735-b596b0882620
- github.com/openbao/openbao (Go): affected all versions; fixed in 0.0.0-20260420155735-b596b0882620
- github.com/openbao/openbao (Go): affected all versions; fixed in 0.0.0-20260420155735-b596b0882620
- openbao (Bitnami): affected all versions; fixed in 2.5.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-39946/ (Markdown: https://insights.sbomify.com/CVE-2026-39946/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-39946
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-39946
- OSV: https://osv.dev/vulnerability/CVE-2026-39946

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-39946/
Summaries are generated and may contain mistakes; the official description above is the record.
