# CVE-2026-39958: oma-topic: name Field in Topic Manifests (topic.json) May Allow CRLF Injection

> A malicious topic manifest can inject CRLF characters into APT source entries, potentially allowing arbitrary code execution or privilege escalation.

- **Severity:** Medium 5.2 (`CVSS:4.0/AV:N/AC:H/AT:P/PR:H/UI:P/VC:N/VI:N/VA:N/SC:H/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 9 Apr 2026
- **Updated:** 13 Apr 2026
- **Also known as:** GHSA-86jc-7r6q-cr3f

## What is CVE-2026-39958?

CVE-2026-39958 is a medium-severity vulnerability in AOSC-Dev oma, published on 9 Apr 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

oma is a package manager for AOSC OS. Prior to 1.25.2, oma-topics is responsible for fetching metadata for testing repositories (topics) named "Topic Manifests" ({mirror}/debs/manifest/topics.json) from remote repository servers, registering them as APT source entries. However, the name field in said metadata were not checked for transliteration. In this case, a malicious party may supply a malformed Topic Manifest, which may cause malicious APT source entries to be added to /etc/apt/sources.list.d/atm.list as oma-topics finishes fetching and registering metadata. This vulnerability is fixed in 1.25.2.

Weakness: CWE-93 (Improper Neutralization of CRLF Sequences)

## Which versions are affected by CVE-2026-39958?


## How do I fix CVE-2026-39958?

No fix has been published for CVE-2026-39958 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-39958 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-39958 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-39958 and fix it if it is affected.

What it is: CVE-2026-39958 is a medium-severity vulnerability in AOSC-Dev oma, published on 9 Apr 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-39958 exists.

Affected product: AOSC-Dev oma. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-39958/ (Markdown: https://insights.sbomify.com/CVE-2026-39958/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-39958
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-39958
- OSV: https://osv.dev/vulnerability/CVE-2026-39958

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-39958/
Summaries are generated and may contain mistakes; the official description above is the record.
