CVE-2026-39960 MantisBT is Vulnerable to Stored XSS through Custom Field Textarea Values

Medium 5.4 Published Updated

Authenticated attackers can inject malicious scripts via custom field textareas, potentially stealing sessions and gaining admin access in MantisBT.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2026-39960?

CVE-2026-39960 is a medium-severity cross-site scripting vulnerability in mantisbt, published on 20 May 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

Mantis Bug Tracker (MantisBT) is an open source issue tracker. Versions 2.28.1 and below contain flawed logic that causes improper escaping of a textarea custom field's contents in the Update Issue page, (bug_update_page.php) allowing an attacker to inject HTML and, if CSP settings permit, execute arbitrary JavaScript when the page is loaded. This facilitates session theft, leading to admin account takeover, full project data access. In order to exploit this issue, a textarea-type custom field must be configured for the project, the attack must be carried out by an authenticated user with bug report permission (low privilege). This can affect any user viewing the bug edit form, including administrators. The issue has been fixed in version 2.28.2. If users cannot immediately upgrade, they can work around the issue by using the default Content-Security Policy, which blocks script execution.

Weakness: CWE-79

Which versions are affected by CVE-2026-39960?

2 open source packages ship an affected version, including mantisbt/mantisbt.

PackageAffectedFixed in
mantisbt/mantisbt PackagistAll versions2.28.2
mantisbt/mantisbt PackagistAll versions2.28.2

How do I fix CVE-2026-39960?

Upgrade mantisbt/mantisbt to 2.28.2 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2026-39960 being exploited?

There is no known exploitation of CVE-2026-39960 in the wild and no public exploit code.

Sources

Also known as GHSA-qj6w-v29q-4rgx.

Is CVE-2026-39960 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free