{"answers":{"affected":"2 open source packages ship an affected version, including mantisbt/mantisbt.","exploited":"There is no known exploitation of CVE-2026-39960 in the wild and no public exploit code.","fix":"Upgrade mantisbt/mantisbt to 2.28.2 or later.","what":"CVE-2026-39960 is a medium-severity cross-site scripting vulnerability in mantisbt, published on 20 May 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-39960 and fix it if it is affected.\n\nWhat it is: CVE-2026-39960 is a medium-severity cross-site scripting vulnerability in mantisbt, published on 20 May 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2026-39960 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- mantisbt/mantisbt (Packagist): affected all versions; fixed in 2.28.2\n- mantisbt/mantisbt (Packagist): affected all versions; fixed in 2.28.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-39960/ (Markdown: https://insights.sbomify.com/CVE-2026-39960/index.md)","id":"CVE-2026-39960","markdown":"https://insights.sbomify.com/CVE-2026-39960/index.md","name":"CVE-2026-39960","record":{"aliases":["GHSA-qj6w-v29q-4rgx"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["account_takeover","data_read"],"network_reachable":"yes","non_default_config":true,"product_category":"Issue tracking system","requires_auth":"low_privilege","summary":"Authenticated attackers can inject malicious scripts via custom field textareas, potentially stealing sessions and gaining admin access in MantisBT.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":5.4,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Mantis Bug Tracker (MantisBT) is an open source issue tracker. Versions 2.28.1 and below contain flawed logic that causes improper escaping of a textarea custom field's contents in the Update Issue page, (bug_update_page.php) allowing an attacker to inject HTML and, if CSP settings permit, execute arbitrary JavaScript when the page is loaded. This facilitates session theft, leading to admin account takeover, full project data access. In order to exploit this issue, a textarea-type custom field must be configured for the project, the attack must be carried out by an authenticated user with bug report permission (low privilege). This can affect any user viewing the bug edit form, including administrators. The issue has been fixed in version 2.28.2. If users cannot immediately upgrade, they can work around the issue by using the default Content-Security Policy, which blocks script execution.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"MantisBT is Vulnerable to Stored XSS through Custom Field Textarea Values","id":"CVE-2026-39960","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2026"},"n_packages":2,"n_references":2,"next":{"headline":"Aiven Operator has cross-namespace secret exfiltration via ClickhouseUser connInfoSecretSource","id":"CVE-2026-39961"},"packages":[{"ecosystem":"Packagist","fixed":["2.28.2"],"introduced":["0"],"last_affected":[],"package":"mantisbt/mantisbt","purl":null,"source":"GHSA-qj6w-v29q-4rgx"},{"ecosystem":"Packagist","fixed":["2.28.2"],"introduced":["0"],"last_affected":[],"package":"mantisbt/mantisbt","purl":"pkg:composer/mantisbt/mantisbt","source":"GHSA-qj6w-v29q-4rgx"}],"prev":{"headline":"Tmds.DBus: malicious D-Bus peers can spoof signals, exhaust file descriptor resources, and cause denial of service","id":"CVE-2026-39959"},"products":["mantisbt"],"published":"2026-05-20","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-05-21","vendors":["mantisbt"]},"summary":"Authenticated attackers can inject malicious scripts via custom field textareas, potentially stealing sessions and gaining admin access in MantisBT.","url":"https://insights.sbomify.com/CVE-2026-39960/"}