# CVE-2026-39976: Laravel Passport's TokenGuard Authenticates Unrelated User for Client Credentials Tokens

> Attackers can use machine-to-machine tokens to authenticate as unrelated real users due to improper validation of client credentials.

- **Severity:** High 7.1 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Apr 2026
- **Updated:** 9 Apr 2026
- **Also known as:** GHSA-349c-2h2f-mxf6

## What is CVE-2026-39976?

CVE-2026-39976 is a high-severity authentication bypass vulnerability in laravel passport, published on 9 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Laravel Passport provides OAuth2 server support to Laravel. From 13.0.0 to before 13.7.1, there is an Authentication Bypass for client_credentials tokens. the league/oauth2-server library sets the JWT sub claim to the client identifier (since there's no user). The token guard then passes this value to retrieveById() without validating it's actually a user identifier, potentially resolving an unrelated real user. Any machine-to-machine token can inadvertently authenticate as an actual user. This vulnerability is fixed in 13.7.1.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2026-39976?

2 open source packages ship an affected version, including laravel/passport. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `laravel/passport` | Packagist | From 13.0.0 | 13.7.1 |
| `laravel/passport` | Packagist | From 13.0.0 | 13.7.1 |

Products: Laravel Passport.

## How do I fix CVE-2026-39976?

Upgrade laravel/passport to 13.7.1 or later.

## Is CVE-2026-39976 being exploited?

There is no known exploitation of CVE-2026-39976 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-39976 and fix it if it is affected.

What it is: CVE-2026-39976 is a high-severity authentication bypass vulnerability in laravel passport, published on 9 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-39976 in the wild and no public exploit code.

Affected packages and fixed versions:
- laravel/passport (Packagist): affected from 13.0.0; fixed in 13.7.1
- laravel/passport (Packagist): affected from 13.0.0; fixed in 13.7.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-39976/ (Markdown: https://insights.sbomify.com/CVE-2026-39976/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-39976
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-39976
- OSV: https://osv.dev/vulnerability/CVE-2026-39976

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-39976/
Summaries are generated and may contain mistakes; the official description above is the record.
