{"answers":{"affected":"1 open source package ship an affected version, including pycti. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-39980 exists.","fix":"Upgrade pycti to 6.9.5 or later.","what":"CVE-2026-39980 is a critical code injection vulnerability in OpenCTI-Platform opencti, published on 9 Apr 2026. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-39980 and fix it if it is affected.\n\nWhat it is: CVE-2026-39980 is a critical code injection vulnerability in OpenCTI-Platform opencti, published on 9 Apr 2026. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-39980 exists.\n\nAffected packages and fixed versions:\n- pycti (PyPI): affected all versions; fixed in 6.9.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-39980/ (Markdown: https://insights.sbomify.com/CVE-2026-39980/index.md)","id":"CVE-2026-39980","markdown":"https://insights.sbomify.com/CVE-2026-39980/index.md","name":"CVE-2026-39980","record":{"aliases":["GHSA-jv9r-jw2f-rhrf","PYSEC-2026-2265"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"OpenCTI threat intelligence","requires_auth":"high_privilege","summary":"Attackers with customization rights can execute arbitrary JavaScript via unsanitized EJS templates in OpenCTI notifier configurations.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"opencti","vendor":"citeum"}],"cvss":{"score":9.1,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-1336","name":"Improper Neutralization of Special Elements Used in a Template Engine"}],"description":"OpenCTI is an open source platform for managing cyber threat intelligence knowledge and observables. Prior to 6.9.5, the safeEjs.ts file does not properly sanitize EJS templates. Users with the Manage customization capability can run arbitrary JavaScript in the context of the OpenCTI platform process during notifier template execution. This vulnerability is fixed in 6.9.5.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":"2026-05-04","github_poc":0,"max_poc_stars":null,"metasploit":1,"nuclei":0,"refs":[{"date":"2026-05-04","kind":"metasploit","ref":"exploit/linux/http/opencti_notifier_rce","stars":null,"title":"OpenCTI Authentication Bypass and Notifier EJS Remote Code Execution"}],"tier":"weaponised"},"has_fix":true,"headline":"OpenCTI affected by RCE via notifier template","id":"CVE-2026-39980","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"code_injection","year":"2026"},"n_packages":1,"n_references":2,"next":{"headline":"AGiXT has a Path Traversal in safe_join()","id":"CVE-2026-39981"},"packages":[{"ecosystem":"PyPI","fixed":["6.9.5"],"introduced":["0"],"last_affected":[],"package":"pycti","purl":"pkg:pypi/pycti","source":"PYSEC-2026-2265"}],"prev":{"headline":"jq: Out-of-Bounds Read in jv_parse_sized() Error Formatting for Non-NUL-Terminated Counted Buffers","id":"CVE-2026-39979"},"products":["opencti"],"published":"2026-04-09","related":[{"cvss_score":9.8,"headline":"OpenCTI privilege escalation and unauthenticated access via default admin account","id":"CVE-2026-27960","kev_date_added":null,"published":"2026-05-05"},{"cvss_score":9.1,"headline":"OpenCTI has remote code execution and sensitive secrets exposed through web hook","id":"CVE-2025-24977","kev_date_added":null,"published":"2025-05-05"},{"cvss_score":8.3,"headline":"OpenCTI Authenticated Privilege Escalation","id":"CVE-2024-26139","kev_date_added":null,"published":"2024-05-23"},{"cvss_score":8.1,"headline":"OpenCTI's lack of Rate Limit lead to OTP brute forcing","id":"CVE-2024-45404","kev_date_added":null,"published":"2024-12-11"},{"cvss_score":7.7,"headline":"OpenCTI has a Semi-Blind SSRF via Unvalidated External URL in Data Ingestion Feature","id":"CVE-2026-21887","kev_date_added":null,"published":"2026-03-12"},{"cvss_score":7.6,"headline":"OpenCTI vulnerable to Denial of Service through web hook","id":"CVE-2025-26621","kev_date_added":null,"published":"2025-05-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"BSD-3-Clause","name":"Metasploit"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-04-09","vendors":["OpenCTI-Platform"]},"summary":"Attackers with customization rights can execute arbitrary JavaScript via unsanitized EJS templates in OpenCTI notifier configurations.","url":"https://insights.sbomify.com/CVE-2026-39980/"}