# CVE-2026-39980: OpenCTI affected by RCE via notifier template

> Attackers with customization rights can execute arbitrary JavaScript via unsanitized EJS templates in OpenCTI notifier configurations.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Apr 2026
- **Updated:** 9 Apr 2026
- **Also known as:** GHSA-jv9r-jw2f-rhrf, PYSEC-2026-2265

## What is CVE-2026-39980?

CVE-2026-39980 is a critical code injection vulnerability in OpenCTI-Platform opencti, published on 9 Apr 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

OpenCTI is an open source platform for managing cyber threat intelligence knowledge and observables. Prior to 6.9.5, the safeEjs.ts file does not properly sanitize EJS templates. Users with the Manage customization capability can run arbitrary JavaScript in the context of the OpenCTI platform process during notifier template execution. This vulnerability is fixed in 6.9.5.

Weakness: CWE-1336 (Improper Neutralization of Special Elements Used in a Template Engine)

## Which versions are affected by CVE-2026-39980?

1 open source package ship an affected version, including pycti. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pycti` | PyPI | All versions | 6.9.5 |

Products: Citeum Opencti.

## How do I fix CVE-2026-39980?

Upgrade pycti to 6.9.5 or later.

## Is CVE-2026-39980 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-39980 exists.

Public exploit code:

- OpenCTI Authentication Bypass and Notifier EJS Remote Code Execution (metasploit)

## Other vulnerabilities in OpenCTI-Platform opencti

- [CVE-2026-27960](https://insights.sbomify.com/CVE-2026-27960/): OpenCTI privilege escalation and unauthenticated access via default admin account (critical 9.8)
- [CVE-2025-24977](https://insights.sbomify.com/CVE-2025-24977/): OpenCTI has remote code execution and sensitive secrets exposed through web hook (critical 9.1)
- [CVE-2024-26139](https://insights.sbomify.com/CVE-2024-26139/): OpenCTI Authenticated Privilege Escalation (high 8.3)
- [CVE-2024-45404](https://insights.sbomify.com/CVE-2024-45404/): OpenCTI's lack of Rate Limit lead to OTP brute forcing (high 8.1)
- [CVE-2026-21887](https://insights.sbomify.com/CVE-2026-21887/): OpenCTI has a Semi-Blind SSRF via Unvalidated External URL in Data Ingestion Feature (high 7.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-39980 and fix it if it is affected.

What it is: CVE-2026-39980 is a critical code injection vulnerability in OpenCTI-Platform opencti, published on 9 Apr 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-39980 exists.

Affected packages and fixed versions:
- pycti (PyPI): affected all versions; fixed in 6.9.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-39980/ (Markdown: https://insights.sbomify.com/CVE-2026-39980/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-39980
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-39980
- OSV: https://osv.dev/vulnerability/CVE-2026-39980

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-39980/
Summaries are generated and may contain mistakes; the official description above is the record.
