CVE-2026-39998 Apache APISIX: Identity Injection via forward-auth Plugin Missing Header Cleanup

Medium 5.8 Published Updated

Attackers can spoof identity headers via the forward-auth plugin, bypassing authentication checks in Apache APISIX.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-39998?

CVE-2026-39998 is a medium-severity authentication bypass vulnerability in Apache APISIX, published on 19 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Improper Input Validation vulnerability in Apache APISIX.

The attacker can take advantage of certain configuration in forward-auth plugin to spoof identity headers. This issue affects Apache APISIX: from 2.12.0 through 3.16.0.

Users are recommended to upgrade to version 3.17.0, which fixes the issue.

Weakness: CWE-20

Which versions are affected by CVE-2026-39998?

1 open source package ship an affected version, including apisix. It affects 1 product.

PackageAffectedFixed in
apisix BitnamiFrom 2.12.03.17.0

Products include Apache Apisix.

How do I fix CVE-2026-39998?

Upgrade apisix to 3.17.0 or later.

Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.

Is CVE-2026-39998 being exploited?

There is no known exploitation of CVE-2026-39998 in the wild and no public exploit code.

Sources

Also known as BIT-apisix-2026-39998, GHSA-86hq-f9pp-3cr9, MINI-g8rj-8f5g-4cqx.

Is CVE-2026-39998 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free