CVE-2026-39999 Apache APISIX: JWT Algorithm Confusion allows authentication bypass

High 7.0 Published Updated

Attackers can bypass authentication in Apache APISIX by exploiting JWT algorithm confusion in specific jwt-auth plugin configurations.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-39999?

CVE-2026-39999 is a high-severity authentication bypass vulnerability in Apache APISIX, published on 19 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Authentication Bypass by Spoofing vulnerability in Apache APISIX.

The attacker can completely bypass authentication capitalising on certain configurations of jwt-auth plugin. This issue affects Apache APISIX: from v2.2 through v3.16.0.

Users are recommended to upgrade to version v3.17.0, which fixes the issue.

Weakness: CWE-290

Which versions are affected by CVE-2026-39999?

1 open source package ship an affected version, including apisix. It affects 1 product.

PackageAffectedFixed in
apisix BitnamiFrom 2.2.03.17.0

Products include Apache Apisix.

How do I fix CVE-2026-39999?

Upgrade apisix to 3.17.0 or later.

Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.

Is CVE-2026-39999 being exploited?

There is no known exploitation of CVE-2026-39999 in the wild and no public exploit code.

Sources

Also known as BIT-apisix-2026-39999, GHSA-pw26-hvcp-w6vj, MINI-cwfj-rp8r-x65q.

Is CVE-2026-39999 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free