CVE-2026-40007 Denial of service in Apache IoTDB

High 7.5 Published Updated

Unauthenticated attackers can cause denial of service via unbounded recursion in the AirGap receiver when enabled, requiring an upgrade to Apache IoTDB.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2026-40007?

CVE-2026-40007 is a high-severity denial of service vulnerability in Apache IoTDB, published on 10 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Uncontrolled Recursion, Uncontrolled Resource Consumption vulnerability in Apache IoTDB. When pipe_air_gap_receiver_enabled=true, the IoTDB AirGap receiver's readLength method calls itself recursively each time it recognises the E-language prefix in socket data, with no depth limit. An unauthenticated attacker can send a stream of repeated E-language prefixes that drives the recursion arbitrarily deep, exhausting the receiver thread's JVM stack and raising StackOverflowError.

This issue affects Apache IoTDB: from 1.0.0 before 2.0.10.

Users are recommended to upgrade to version 2.0.10, which fixes the issue.

Weakness: CWE-674, CWE-400

Which versions are affected by CVE-2026-40007?

How do I fix CVE-2026-40007?

No fix has been published for CVE-2026-40007 yet. Limit exposure of the affected software until one is available.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2026-40007 being exploited?

There is no known exploitation of CVE-2026-40007 in the wild and no public exploit code.

Sources

Also known as GHSA-4644-hpfg-x44q.

Is CVE-2026-40007 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free