{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2026-40007 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2026-40007 yet. Limit exposure of the affected software until one is available.","what":"CVE-2026-40007 is a high-severity denial of service vulnerability in Apache IoTDB, published on 10 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-40007 and fix it if it is affected.\n\nWhat it is: CVE-2026-40007 is a high-severity denial of service vulnerability in Apache IoTDB, published on 10 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-40007 in the wild and no public exploit code.\n\nAffected product: Apache IoTDB. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-40007/ (Markdown: https://insights.sbomify.com/CVE-2026-40007/index.md)","id":"CVE-2026-40007","markdown":"https://insights.sbomify.com/CVE-2026-40007/index.md","name":"CVE-2026-40007","record":{"aliases":["GHSA-4644-hpfg-x44q"],"analysis":{"component_type":"database","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":true,"product_category":"Apache IoTDB","requires_auth":"none","summary":"Unauthenticated attackers can cause denial of service via unbounded recursion in the AirGap receiver when enabled, requiring an upgrade to Apache IoTDB.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[],"cvss":{"score":7.5,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-674","name":"Uncontrolled Recursion"},{"id":"CWE-400","name":"Uncontrolled Resource Consumption"}],"description":"Uncontrolled Recursion, Uncontrolled Resource Consumption vulnerability in Apache IoTDB.\nWhen pipe_air_gap_receiver_enabled=true, the IoTDB AirGap receiver's\nreadLength method calls itself recursively each time it recognises the\nE-language prefix in socket data, with no depth limit. An unauthenticated\nattacker can send a stream of repeated E-language prefixes that drives the\nrecursion arbitrarily deep, exhausting the receiver thread's JVM stack and\nraising StackOverflowError.\n\nThis issue affects Apache IoTDB: from 1.0.0 before 2.0.10.\n\nUsers are recommended to upgrade to version 2.0.10, which fixes the issue.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":null,"headline":"Denial of service in Apache IoTDB","id":"CVE-2026-40007","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"denial_of_service","year":"2026"},"n_packages":0,"n_references":1,"next":{"headline":"Apache IoTDB: Arbitrary Class Instantiation via Pipe Transfer RPC","id":"CVE-2026-40008"},"packages":[],"prev":{"headline":"Apache IoTDB: Unauthenticated heap-exhaustion DoS via unbounded allocation in IoTDB AirGap pipe receiver","id":"CVE-2026-40006"},"products":["Apache IoTDB"],"published":"2026-07-10","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-07-10","vendors":["Apache Software Foundation"]},"summary":"Unauthenticated attackers can cause denial of service via unbounded recursion in the AirGap receiver when enabled, requiring an upgrade to Apache IoTDB.","url":"https://insights.sbomify.com/CVE-2026-40007/"}