CVE-2026-40022 Apache Camel Platform HTTP Main: Authentication Bypass on Non-Root Context Paths in camel main runtime

High 8.2 Published Updated

Attackers can bypass authentication on non-root context paths in Apache Camel HTTP Main, accessing protected routes and disclosing runtime metadata.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-40022?

CVE-2026-40022 is a high-severity authentication bypass vulnerability in Apache Camel, published on 27 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

When authentication is enabled on the Apache Camel embedded HTTP server or embedded management server (camel-platform-http-main) and a non-root context path such as /api or /admin is configured via camel.server.path or camel.management.path, the BasicAuthenticationConfigurer and JWTAuthenticationConfigurer classes derive the authentication path from properties.getPath() when camel.server.authenticationPath / camel.management.authenticationPath is not explicitly set. Combined with the Vert.x sub-router mounting model - the sub-router is mounted at _path_* and the authentication handler is registered inside the sub-router at the resolved path - this causes the authentication handler to match only the exact configured context path, not its subpaths. Unauthenticated requests to subpaths such as /api/_route_ or /admin/observe/info therefore reach protected business routes and management endpoints without being challenged for credentials. The /observe/info endpoint can disclose runtime metadata such as the user, working directory, home directory, process ID, JVM and operating system information.

This issue affects Apache Camel: from 4.14.1 before 4.14.6, from 4.18.0 before 4.18.2.

Users are recommended to upgrade to version 4.20.0, which fixes the issue. If users are on the 4.14.x LTS releases stream, they are suggested to upgrade to 4.14.6. If users are on the 4.18.x LTS releases stream, they are suggested to upgrade to 4.18.2.

Weakness: CWE-551, CWE-288

Which versions are affected by CVE-2026-40022?

6 open source packages ship an affected version, including org.apache.camel:camel-platform-http-main. It affects 1 product.

PackageAffectedFixed in
org.apache.camel:camel-platform-http-main MavenFrom 4.14.14.14.6
org.apache.camel:camel-platform-http-main MavenFrom 4.14.14.14.6
org.apache.camel:camel-platform-http-main MavenFrom 4.18.04.18.2
org.apache.camel:camel-platform-http-main MavenFrom 4.18.04.18.2
org.apache.camel:camel-platform-http-main MavenFrom 4.19.04.20.0
org.apache.camel:camel-platform-http-main MavenFrom 4.19.04.20.0

Products include Apache Camel.

How do I fix CVE-2026-40022?

Upgrade org.apache.camel:camel-platform-http-main to a fixed version for your release line: 4.14.6, 4.18.2 or 4.20.0.

Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.

Is CVE-2026-40022 being exploited?

There is no known exploitation of CVE-2026-40022 in the wild and no public exploit code.

Public exploit code: 1 proofs of concept on GitHub.

All Apache Camel vulnerabilities

Sources

Also known as GHSA-27vm-5vpj-rp5g.

Is CVE-2026-40022 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free