# CVE-2026-40022: Apache Camel Platform HTTP Main: Authentication Bypass on Non-Root Context Paths in camel main runtime

> Attackers can bypass authentication on non-root context paths in Apache Camel HTTP Main, accessing protected routes and disclosing runtime metadata.

- **Severity:** High 8.2 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Apr 2026
- **Updated:** 15 Jul 2026
- **Also known as:** GHSA-27vm-5vpj-rp5g

## What is CVE-2026-40022?

CVE-2026-40022 is a high-severity authentication bypass vulnerability in Apache Camel, published on 27 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

When authentication is enabled on the Apache Camel embedded HTTP server or embedded management server (camel-platform-http-main) and a non-root context path such as /api or /admin is configured via camel.server.path or camel.management.path, the BasicAuthenticationConfigurer and JWTAuthenticationConfigurer classes derive the authentication path from properties.getPath() when camel.server.authenticationPath / camel.management.authenticationPath is not explicitly set. Combined with the Vert.x sub-router mounting model - the sub-router is mounted at _path_* and the authentication handler is registered inside the sub-router at the resolved path - this causes the authentication handler to match only the exact configured context path, not its subpaths. Unauthenticated requests to subpaths such as /api/_route_ or /admin/observe/info therefore reach protected business routes and management endpoints without being challenged for credentials. The /observe/info endpoint can disclose runtime metadata such as the user, working directory, home directory, process ID, JVM and operating system information.

This issue affects Apache Camel: from 4.14.1 before 4.14.6, from 4.18.0 before 4.18.2.

Users are recommended to upgrade to version 4.20.0, which fixes the issue. If users are on the 4.14.x LTS releases stream, they are suggested to upgrade to 4.14.6. If users are on the 4.18.x LTS releases stream, they are suggested to upgrade to 4.18.2.

Weakness: CWE-551 (Incorrect Behavior Order: Authorization Before Parsing and Canonicalization), CWE-288 (Authentication Bypass Using an Alternate Path or Channel)

## Which versions are affected by CVE-2026-40022?

6 open source packages ship an affected version, including org.apache.camel:camel-platform-http-main. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.camel:camel-platform-http-main` | Maven | From 4.14.1 | 4.14.6 |
| `org.apache.camel:camel-platform-http-main` | Maven | From 4.14.1 | 4.14.6 |
| `org.apache.camel:camel-platform-http-main` | Maven | From 4.18.0 | 4.18.2 |
| `org.apache.camel:camel-platform-http-main` | Maven | From 4.18.0 | 4.18.2 |
| `org.apache.camel:camel-platform-http-main` | Maven | From 4.19.0 | 4.20.0 |
| `org.apache.camel:camel-platform-http-main` | Maven | From 4.19.0 | 4.20.0 |

Products: Apache Camel.

## How do I fix CVE-2026-40022?

Upgrade org.apache.camel:camel-platform-http-main to a fixed version for your release line: 4.14.6, 4.18.2 or 4.20.0.

## Is CVE-2026-40022 being exploited?

There is no known exploitation of CVE-2026-40022 in the wild and no public exploit code.

Public exploit code:

- Reproducer for CVE-2026-40022: Apache Camel camel-platform-http-main authentication bypass on non-root context paths (github_poc): https://github.com/oscerd/CVE-2026-40022

## Other vulnerabilities in Apache Camel

- [CVE-2026-33453](https://insights.sbomify.com/CVE-2026-33453/): Apache camel-coap allows header injection that can lead to remote code execution (critical 10.0)
- [CVE-2026-40453](https://insights.sbomify.com/CVE-2026-40453/): Apache Camel has an incomplete fix for CVE-2025-27636 (critical 9.9)
- [CVE-2026-80351](https://insights.sbomify.com/CVE-2026-80351/): Apache Camel K: Camel K Tenant repositories reach Maven execution inside operator pod (critical 9.8)
- [CVE-2026-80352](https://insights.sbomify.com/CVE-2026-80352/): Apache Camel K: Camel K Master trait serviceAccountName YAML injection lets CR author apply arbitrary objects (critical 9.8)
- [CVE-2026-71300](https://insights.sbomify.com/CVE-2026-71300/): Apache Camel: Camel-Atmosphere-Websocket: WebSocket dispatch header injection (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-40022 and fix it if it is affected.

What it is: CVE-2026-40022 is a high-severity authentication bypass vulnerability in Apache Camel, published on 27 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-40022 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.camel:camel-platform-http-main (Maven): affected from 4.14.1; fixed in 4.14.6
- org.apache.camel:camel-platform-http-main (Maven): affected from 4.14.1; fixed in 4.14.6
- org.apache.camel:camel-platform-http-main (Maven): affected from 4.18.0; fixed in 4.18.2
- org.apache.camel:camel-platform-http-main (Maven): affected from 4.18.0; fixed in 4.18.2
- org.apache.camel:camel-platform-http-main (Maven): affected from 4.19.0; fixed in 4.20.0
- org.apache.camel:camel-platform-http-main (Maven): affected from 4.19.0; fixed in 4.20.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-40022/ (Markdown: https://insights.sbomify.com/CVE-2026-40022/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-40022
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-40022
- OSV: https://osv.dev/vulnerability/CVE-2026-40022

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-40022/
Summaries are generated and may contain mistakes; the official description above is the record.
