{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-40023 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2026-40023 is a medium-severity vulnerability in Apache Log4cxx, published on 10 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-40023 and fix it if it is affected.\n\nWhat it is: CVE-2026-40023 is a medium-severity vulnerability in Apache Log4cxx, published on 10 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-40023 in the wild and no public exploit code.\n\nAffected product: Apache Log4cxx. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-40023/ (Markdown: https://insights.sbomify.com/CVE-2026-40023/index.md)","id":"CVE-2026-40023","markdown":"https://insights.sbomify.com/CVE-2026-40023/index.md","name":"CVE-2026-40023","record":{"aliases":["DEBIAN-CVE-2026-40023","GHSA-q8qr-wp2r-738r","MGASA-2026-0218","UBUNTU-CVE-2026-40023","openSUSE-SU-2026:10566-1","openSUSE-SU-2026:20705-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_modify","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Java logging library","requires_auth":"none","summary":"Attackers can suppress log records by injecting forbidden XML characters, impairing audit trails and detection in applications using Apache Log4cxx.","user_interaction":"not_required","vuln_class":"other"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"log4cxx","vendor":"apache"}],"cvss":{"score":6.3,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:N/VI:N/VA:N/SC:N/SI:L/SA:N","version":"4.0"},"cwes":[{"id":"CWE-116","name":"Improper Encoding or Escaping of Output"}],"description":"Apache Log4cxx's  XMLLayout https://logging.apache.org/log4cxx/1.7.0/classlog4cxx_1_1xml_1_1XMLLayout.html , in versions before 1.7.0, fails to sanitize characters forbidden by the  XML 1.0 specification https://www.w3.org/TR/xml/#charsets  in log messages, NDC, and MDC property keys and values, producing invalid XML output. Conforming XML parsers must reject such documents with a fatal error, which may cause downstream log processing systems to drop or fail to index affected records.\n\nAn attacker who can influence logged data can exploit this to suppress individual log records, impairing audit trails and detection of malicious activity.\n\nUsers are advised to upgrade to Apache Log4cxx 1.7.0, which fixes this issue.","ecosystems":["openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Other in Apache Log4cxx","id":"CVE-2026-40023","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"other","year":"2026"},"n_packages":1,"n_references":5,"next":{"headline":"Sleuth Kit tsk_recover Path Traversal","id":"CVE-2026-40024"},"packages":[{"ecosystem":"openSUSE:Tumbleweed","fixed":["1.7.0-2.1"],"introduced":["0"],"last_affected":[],"package":"log4cxx","purl":"pkg:rpm/opensuse/log4cxx\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2026:10566-1"}],"prev":{"headline":"Apache Camel Platform HTTP Main: Authentication Bypass on Non-Root Context Paths in camel main runtime","id":"CVE-2026-40022"},"products":["Apache Log4cxx","Apache Log4cxx (Brew)","Apache Log4cxx (Conan)"],"published":"2026-04-10","related":[{"cvss_score":8.8,"headline":"Apache Log4cxx: SQL injection when using ODBC appender","id":"CVE-2023-31038","kev_date_added":null,"published":"2023-05-08"},{"cvss_score":6.3,"headline":"Apache Log4cxx: Improper escaping with JSONLayout","id":"CVE-2025-54813","kev_date_added":null,"published":"2025-08-22"},{"cvss_score":2.1,"headline":"Apache Log4cxx: Improper HTML escaping in HTMLLayout","id":"CVE-2025-54812","kev_date_added":null,"published":"2025-08-22"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-04-10","vendors":["Apache Software Foundation"]},"summary":"Attackers can suppress log records by injecting forbidden XML characters, impairing audit trails and detection in applications using Apache Log4cxx.","url":"https://insights.sbomify.com/CVE-2026-40023/"}