{"answers":{"affected":"2 open source packages ship an affected version, including gix.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-40034 exists.","fix":"Upgrade gix to 0.83.0 or later.","what":"CVE-2026-40034 is a high-severity command injection vulnerability in gitoxide, published on 26 May 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-40034 and fix it if it is affected.\n\nWhat it is: CVE-2026-40034 is a high-severity command injection vulnerability in gitoxide, published on 26 May 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-40034 exists.\n\nAffected packages and fixed versions:\n- gix (crates.io): affected from 0.31.0; fixed in 0.83.0\n- gix (crates.io): affected from 0.31.0; fixed in 0.83.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-40034/ (Markdown: https://insights.sbomify.com/CVE-2026-40034/index.md)","id":"CVE-2026-40034","markdown":"https://insights.sbomify.com/CVE-2026-40034/index.md","name":"CVE-2026-40034","record":{"aliases":["AZL-89292","AZL-89295","DEBIAN-CVE-2026-40034","GHSA-f26g-jm89-4g65","MINI-q664-jrjx-6mhj","UBUNTU-CVE-2026-40034","openSUSE-SU-2026:11038-1","openSUSE-SU-2026:12338-1","openSUSE-SU-2026:21185-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Git library","requires_auth":"none","summary":"Attackers can execute arbitrary shell commands via malicious .gitmodules configuration in gix-submodule, leading to remote code execution.","user_interaction":"required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[],"cvss":{"score":7.3,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-77","name":"Improper Neutralization of Special Elements used in a Command"}],"description":"gix-submodule before 0.29.0 (gitoxide before 0.5.21, gix before 0.84.0) incorrectly validates the update field in .gitmodules, allowing attackers to bypass the CommandForbiddenInModulesConfiguration guard when a submodule has been initialized with only partial configuration in .git/config. An attacker can inject arbitrary shell commands via the update field in .gitmodules that will be executed when Submodule::update() is called on a previously-initialized submodule, enabling remote code execution.","ecosystems":["crates.io","openSUSE:Leap 16.0","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"gitoxide - Command Injection via Partial .gitmodules Override in gix-submodule","id":"CVE-2026-40034","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"command_injection","year":"2026"},"n_packages":5,"n_references":5,"next":{"headline":"Unfurl - Werkzeug Debugger Exposure via String Config Parsing","id":"CVE-2026-40035"},"packages":[{"ecosystem":"crates.io","fixed":["0.83.0"],"introduced":["0.31.0"],"last_affected":[],"package":"gix","purl":null,"source":"GHSA-f26g-jm89-4g65"},{"ecosystem":"crates.io","fixed":["0.83.0"],"introduced":["0.31.0"],"last_affected":[],"package":"gix","purl":"pkg:cargo/gix","source":"GHSA-f26g-jm89-4g65"},{"ecosystem":"openSUSE:Leap 16.0","fixed":["2.6.0-bp160.1.1"],"introduced":["0"],"last_affected":[],"package":"stgit","purl":"pkg:rpm/opensuse/stgit\u0026distro=openSUSE%20Leap%2016.0","source":"openSUSE-SU-2026:21185-1"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["2.6.0-1.1"],"introduced":["0"],"last_affected":[],"package":"stgit","purl":"pkg:rpm/opensuse/stgit\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2026:11038-1"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["2.8.0-1.1"],"introduced":["0"],"last_affected":[],"package":"watchexec","purl":"pkg:rpm/opensuse/watchexec\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2026:12338-1"}],"prev":{"headline":"FreeRDP - Heap-buffer-overflow in gdi_CacheToSurface via rectangle validation bypass","id":"CVE-2026-40033"},"products":["gitoxide","gix","gix-submodule"],"published":"2026-05-26","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-10-08","vendors":["gitoxide"]},"summary":"Attackers can execute arbitrary shell commands via malicious .gitmodules configuration in gix-submodule, leading to remote code execution.","url":"https://insights.sbomify.com/CVE-2026-40034/"}