{"answers":{"affected":"7 open source packages ship an affected version, including org.apache.activemq:activemq-all, activemq and org.apache.activemq:activemq-mqtt.","exploited":"There is no known exploitation of CVE-2026-40046 in the wild and no public exploit code.","fix":"Upgrade org.apache.activemq:activemq-all to 6.2.4 or later.","what":"CVE-2026-40046 is a high-severity vulnerability in Apache ActiveMQ, published on 9 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-40046 and fix it if it is affected.\n\nWhat it is: CVE-2026-40046 is a high-severity vulnerability in Apache ActiveMQ, published on 9 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-40046 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.activemq:activemq-all (Maven): affected from 6.0.0; fixed in 6.2.4\n- org.apache.activemq:activemq-all (Maven): affected from 6.0.0; fixed in 6.2.4\n- activemq (Bitnami): affected from 6.0.0; fixed in 6.2.4\n- org.apache.activemq:activemq-mqtt (Maven): affected from 6.0.0; fixed in 6.2.4\n- org.apache.activemq:activemq-mqtt (Maven): affected from 6.0.0; fixed in 6.2.4\n- org.apache.activemq:apache-activemq (Maven): affected from 6.0.0; fixed in 6.2.4\n- org.apache.activemq:apache-activemq (Maven): affected from 6.0.0; fixed in 6.2.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-40046/ (Markdown: https://insights.sbomify.com/CVE-2026-40046/index.md)","id":"CVE-2026-40046","markdown":"https://insights.sbomify.com/CVE-2026-40046/index.md","name":"CVE-2026-40046","record":{"aliases":["BIT-activemq-2026-40046","GHSA-xvqc-pp94-fmpx","MINI-2357-m62r-g5h3","MINI-5755-w8q6-8rcm","MINI-9545-h8fw-8wxx","MINI-vq2w-rqhm-q6r8","ROOT-APP-MAVEN-CVE-2026-40046","UBUNTU-CVE-2026-40046"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service","code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache ActiveMQ MQTT","requires_auth":"none","summary":"An integer overflow in MQTT packet validation allows attackers to cause denial of service or potentially execute code on Apache ActiveMQ servers.","user_interaction":"not_required","vuln_class":"integer_overflow"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[],"cvss":{"score":7.5,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-190","name":"Integer Overflow or Wraparound"}],"description":"Integer Overflow or Wraparound vulnerability in Apache ActiveMQ, Apache ActiveMQ All, Apache ActiveMQ MQTT.\n\nThe fix for \"CVE-2025-66168: MQTT control packet remaining length field is not properly validated\" was only applied to 5.19.2 (and future 5.19.x) releases but was missed for all 6.0.0+ versions.\n\nThis issue affects Apache ActiveMQ: from 6.0.0 before 6.2.4; Apache ActiveMQ All: from 6.0.0 before 6.2.4; Apache ActiveMQ MQTT: from 6.0.0 before 6.2.4.\n\nUsers are recommended to upgrade to version 6.2.4 or a 5.19.x version starting with 5.19.2 or later (currently latest is 5.19.5), which fixes the issue.","ecosystems":["Bitnami","Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache ActiveMQ, Apache ActiveMQ All, Apache ActiveMQ MQTT vulnerable to Integer Overflow or Wraparound","id":"CVE-2026-40046","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"integer_overflow","year":"2026"},"n_packages":7,"n_references":3,"next":{"headline":"Apache Camel-Docling: Insufficient validation of custom CLI arguments enables argument injection and path traversal in DoclingProducer","id":"CVE-2026-40047"},"packages":[{"ecosystem":"Bitnami","fixed":["6.2.4"],"introduced":["6.0.0"],"last_affected":[],"package":"activemq","purl":"pkg:bitnami/activemq","source":"BIT-activemq-2026-40046"},{"ecosystem":"Maven","fixed":["6.2.4"],"introduced":["6.0.0"],"last_affected":[],"package":"org.apache.activemq:activemq-all","purl":null,"source":"GHSA-xvqc-pp94-fmpx"},{"ecosystem":"Maven","fixed":["6.2.4"],"introduced":["6.0.0"],"last_affected":[],"package":"org.apache.activemq:activemq-all","purl":"pkg:maven/org.apache.activemq/activemq-all","source":"GHSA-xvqc-pp94-fmpx"},{"ecosystem":"Maven","fixed":["6.2.4"],"introduced":["6.0.0"],"last_affected":[],"package":"org.apache.activemq:activemq-mqtt","purl":null,"source":"GHSA-xvqc-pp94-fmpx"},{"ecosystem":"Maven","fixed":["6.2.4"],"introduced":["6.0.0"],"last_affected":[],"package":"org.apache.activemq:activemq-mqtt","purl":"pkg:maven/org.apache.activemq/activemq-mqtt","source":"GHSA-xvqc-pp94-fmpx"},{"ecosystem":"Maven","fixed":["6.2.4"],"introduced":["6.0.0"],"last_affected":[],"package":"org.apache.activemq:apache-activemq","purl":null,"source":"GHSA-xvqc-pp94-fmpx"},{"ecosystem":"Maven","fixed":["6.2.4"],"introduced":["6.0.0"],"last_affected":[],"package":"org.apache.activemq:apache-activemq","purl":"pkg:maven/org.apache.activemq/apache-activemq","source":"GHSA-xvqc-pp94-fmpx"}],"prev":{"headline":"OpenClaw \u003c 2026.4.2 - Cleartext Credential Transmission via Unencrypted WebSocket Gateway Endpoints","id":"CVE-2026-40045"},"products":["Apache ActiveMQ","Apache ActiveMQ All","Apache ActiveMQ MQTT"],"published":"2026-04-09","related":[],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-04-10","vendors":["Apache Software Foundation"]},"summary":"An integer overflow in MQTT packet validation allows attackers to cause denial of service or potentially execute code on Apache ActiveMQ servers.","url":"https://insights.sbomify.com/CVE-2026-40046/"}