# CVE-2026-40048: Apache Camel PQC: Unsafe Deserialization from FileBasedKeyLifecycleManager

> An attacker with write access to the key directory can achieve arbitrary code execution via unsafe Java deserialization in Apache Camel PQC.

- **Severity:** High 7.8 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Apr 2026
- **Updated:** 15 Jul 2026
- **Also known as:** GHSA-v3vg-332r-mw99

## What is CVE-2026-40048?

CVE-2026-40048 is a high-severity unsafe deserialization vulnerability in Apache Camel, published on 27 Apr 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

The Camel-PQC FileBasedKeyLifecycleManager class deserializes the contents of `<keyId>.key` files in the configured key directory using java.io.ObjectInputStream without applying any ObjectInputFilter or class-loading restrictions. The cast to `java.security.KeyPair` is evaluated only after `readObject()` has already returned, so any `readObject()` side effects in the deserialized object run before the type check. An attacker who can write to the key directory used by a Camel application — for example through a path traversal into the directory, misconfigured filesystem permissions on the volume where keys are stored, a compromised key provisioning pipeline, or a symlink attack — can place a crafted serialized Java object that, when deserialized during normal key lifecycle operations, results in arbitrary code execution in the context of the application.

This issue affects Apache Camel: from 4.19.0 before 4.20.0, from 4.18.0 before 4.18.2.

Users are recommended to upgrade to version 4.20.0, which fixes the issue by replacing java.io.ObjectInputStream-based key and metadata storage with standard PKCS#8 (private key) / X.509 SubjectPublicKeyInfo (public key) Base64 JSON encoding. For users on the 4.18.x LTS releases stream, upgrade to 4.18.2.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2026-40048?

2 open source packages ship an affected version, including org.apache.camel:camel-pqc. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.camel:camel-pqc` | Maven | All versions | 4.18.2 |
| `org.apache.camel:camel-pqc` | Maven | All versions | 4.18.2 |

Products: Apache Camel.

## How do I fix CVE-2026-40048?

Upgrade org.apache.camel:camel-pqc to 4.18.2 or later.

## Is CVE-2026-40048 being exploited?

There is no known exploitation of CVE-2026-40048 in the wild and no public exploit code.

Public exploit code:

- Reproducer for CVE-2026-40048: Apache Camel camel-pqc FileBasedKeyLifecycleManager unsafe deserialization (RCE) (github_poc): https://github.com/oscerd/CVE-2026-40048

## Other vulnerabilities in Apache Camel

- [CVE-2026-33453](https://insights.sbomify.com/CVE-2026-33453/): Apache camel-coap allows header injection that can lead to remote code execution (critical 10.0)
- [CVE-2026-40453](https://insights.sbomify.com/CVE-2026-40453/): Apache Camel has an incomplete fix for CVE-2025-27636 (critical 9.9)
- [CVE-2026-80351](https://insights.sbomify.com/CVE-2026-80351/): Apache Camel K: Camel K Tenant repositories reach Maven execution inside operator pod (critical 9.8)
- [CVE-2026-80352](https://insights.sbomify.com/CVE-2026-80352/): Apache Camel K: Camel K Master trait serviceAccountName YAML injection lets CR author apply arbitrary objects (critical 9.8)
- [CVE-2026-71300](https://insights.sbomify.com/CVE-2026-71300/): Apache Camel: Camel-Atmosphere-Websocket: WebSocket dispatch header injection (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-40048 and fix it if it is affected.

What it is: CVE-2026-40048 is a high-severity unsafe deserialization vulnerability in Apache Camel, published on 27 Apr 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-40048 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.camel:camel-pqc (Maven): affected all versions; fixed in 4.18.2
- org.apache.camel:camel-pqc (Maven): affected all versions; fixed in 4.18.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-40048/ (Markdown: https://insights.sbomify.com/CVE-2026-40048/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-40048
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-40048
- OSV: https://osv.dev/vulnerability/CVE-2026-40048

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-40048/
Summaries are generated and may contain mistakes; the official description above is the record.
