# CVE-2026-40068: Claude Code arbitrary code execution via git worktree commondir trust dialog bypass

> Attackers can execute arbitrary code by bypassing trust dialogs via malicious git worktree configurations in Claude Code.

- **Severity:** High 7.7 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 5 May 2026
- **Updated:** 6 May 2026
- **Also known as:** GHSA-q5hj-mxqh-vv77, MINI-79c8-vcm6-8w87, MINI-89f8-p2c9-3w6j

## What is CVE-2026-40068?

CVE-2026-40068 is a high-severity code injection vulnerability in anthropics claude-code, published on 5 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

In versions 2.1.63 through 2.1.83 of Claude Code, the folder trust determination logic used the git worktree commondir file without validating its contents. An attacker could craft a malicious repository with a commondir file pointing to a path the victim had previously trusted, causing Claude Code to bypass its trust confirmation dialog and immediately execute hooks defined in `.claude/settings.json`. Exploitation requires the victim to clone the malicious repository and run Claude Code within it, and the attacker must know or guess a path the victim had already trusted. This issue has been fixed in version 2.1.84.

Weakness: CWE-77 (Improper Neutralization of Special Elements used in a Command), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2026-40068?

2 open source packages ship an affected version, including @anthropic-ai/claude-code. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@anthropic-ai/claude-code` | npm | From 2.1.63 | 2.1.84 |
| `@anthropic-ai/claude-code` | npm | From 2.1.63 | 2.1.84 |

Products: Anthropic Claude Code.

## How do I fix CVE-2026-40068?

Upgrade @anthropic-ai/claude-code to 2.1.84 or later.

## Is CVE-2026-40068 being exploited?

There is no known exploitation of CVE-2026-40068 in the wild and no public exploit code.

## Other vulnerabilities in anthropics claude-code

- [CVE-2025-66032](https://insights.sbomify.com/CVE-2025-66032/): Claude Code Command Validation Bypass Allows Arbitrary Code Execution (high 8.7)
- [CVE-2025-64755](https://insights.sbomify.com/CVE-2025-64755/): @anthropic-ai/claude-code has Sed Command Validation Bypass that Allows Arbitrary File Writes (high 8.7)
- [CVE-2025-59536](https://insights.sbomify.com/CVE-2025-59536/): Claude Code's startup trust dialog could lead to Command Execution attack (high 8.7)
- [CVE-2025-58764](https://insights.sbomify.com/CVE-2025-58764/): Claude Code rg command had Command Injection that allowed bypass of user approval prompt for command execution (high 8.7)
- [CVE-2025-59041](https://insights.sbomify.com/CVE-2025-59041/): Claude Code vulnerable to arbitrary code execution caused by maliciously configured git email (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-40068 and fix it if it is affected.

What it is: CVE-2026-40068 is a high-severity code injection vulnerability in anthropics claude-code, published on 5 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-40068 in the wild and no public exploit code.

Affected packages and fixed versions:
- @anthropic-ai/claude-code (npm): affected from 2.1.63; fixed in 2.1.84
- @anthropic-ai/claude-code (npm): affected from 2.1.63; fixed in 2.1.84

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-40068/ (Markdown: https://insights.sbomify.com/CVE-2026-40068/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-40068
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-40068
- OSV: https://osv.dev/vulnerability/CVE-2026-40068

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-40068/
Summaries are generated and may contain mistakes; the official description above is the record.
