# CVE-2026-40069: bsv-sdk ARC broadcaster treats INVALID/MALFORMED/ORPHAN responses as successful broadcasts

> The BSV Ruby SDK incorrectly treats invalid blockchain transactions as successful, potentially leading to data integrity issues in applications relying on broadcast confirmation.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Apr 2026
- **Updated:** 13 Apr 2026
- **Also known as:** GHSA-9hfr-gw99-8rhx

## What is CVE-2026-40069?

CVE-2026-40069 is a high-severity vulnerability in sgbett bsv-ruby-sdk, published on 9 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

BSV Ruby SDK is the Ruby SDK for the BSV blockchain. From 0.1.0 to before 0.8.2, BSV::Network::ARC's failure detection only recognises REJECTED and DOUBLE_SPEND_ATTEMPTED. ARC responses with txStatus values of INVALID, MALFORMED, MINED_IN_STALE_BLOCK, or any ORPHAN-containing extraInfo / txStatus are silently treated as successful broadcasts. Applications that gate actions on broadcaster success are tricked into trusting transactions that were never accepted by the network. This vulnerability is fixed in 0.8.2.

Weakness: CWE-754 (Improper Check for Unusual or Exceptional Conditions)

## Which versions are affected by CVE-2026-40069?

2 open source packages ship an affected version, including bsv-sdk. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `bsv-sdk` | RubyGems | From 0.1.0 | 0.8.2 |
| `bsv-sdk` | RubyGems | From 0.1.0 | 0.8.2 |

Products: Sgbett Bsv Ruby Sdk.

## How do I fix CVE-2026-40069?

Upgrade bsv-sdk to 0.8.2 or later.

## Is CVE-2026-40069 being exploited?

There is no known exploitation of CVE-2026-40069 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-40069 and fix it if it is affected.

What it is: CVE-2026-40069 is a high-severity vulnerability in sgbett bsv-ruby-sdk, published on 9 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-40069 in the wild and no public exploit code.

Affected packages and fixed versions:
- bsv-sdk (RubyGems): affected from 0.1.0; fixed in 0.8.2
- bsv-sdk (RubyGems): affected from 0.1.0; fixed in 0.8.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-40069/ (Markdown: https://insights.sbomify.com/CVE-2026-40069/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-40069
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-40069
- OSV: https://osv.dev/vulnerability/CVE-2026-40069

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-40069/
Summaries are generated and may contain mistakes; the official description above is the record.
