CVE-2026-40075 OpenMRS Core arbitrary file read via path traversal in ModuleResourcesServlet
Unauthenticated attackers can read arbitrary files, including credentials, via path traversal in OpenMRS Core when running on vulnerable Tomcat versions.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-40075?
CVE-2026-40075 is a high-severity path traversal vulnerability in openmrs-core, published on 5 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
OpenMRS Core is an open source electronic medical record system platform. In versions 2.7.8 and earlier and versions 2.8.0 through 2.8.5, the `/openmrs/moduleResources/{moduleid}` endpoint is vulnerable to a path traversal attack. The ModuleResourcesServlet constructs a filesystem path from user-controlled input without performing path boundary validation — the getFile() method concatenates the user-supplied path into an absolute filesystem path without calling normalize() or checking that the result stays within the allowed module resources directory. Because this endpoint serves static resources required for rendering the login page, it is not protected by authentication filters, allowing unauthenticated exploitation.
An attacker can traverse directories and read arbitrary files from the server filesystem, including /etc/passwd and application configuration files containing database credentials. Successful exploitation requires the target deployment to run on Apache Tomcat versions prior to 8.5.31, where the ..; path parameter bypass is not mitigated by the container. Deployments on Tomcat 8.5.31 or later and Tomcat 9.0.10 or later are protected at the container level, though the underlying code defect remains. This issue has been fixed in versions after 2.7.8 (within the 2.7.x branch) and in version 2.8.6 and later.
Weakness: CWE-22
Which versions are affected by CVE-2026-40075?
4 open source packages ship an affected version, including org.openmrs.web:openmrs-web. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.openmrs.web:openmrs-web Maven | All versions to 2.7.8 | None |
org.openmrs.web:openmrs-web Maven | All versions to 2.7.8 | None |
org.openmrs.web:openmrs-web Maven | From 2.8.0 | 2.8.6 |
org.openmrs.web:openmrs-web Maven | From 2.8.0 | 2.8.6 |
Products include Openmrs Openmrs.
How do I fix CVE-2026-40075?
Upgrade org.openmrs.web:openmrs-web to 2.8.6 or later.
Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.
Is CVE-2026-40075 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-40075 exists.
Other vulnerabilities in openmrs-core
Sources
Also known as GHSA-jjgj-cx3q-pw4w.