# CVE-2026-40075: OpenMRS Core arbitrary file read via path traversal in ModuleResourcesServlet

> Unauthenticated attackers can read arbitrary files, including credentials, via path traversal in OpenMRS Core when running on vulnerable Tomcat versions.

- **Severity:** High 8.2 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 May 2026
- **Updated:** 6 May 2026
- **Also known as:** GHSA-jjgj-cx3q-pw4w

## What is CVE-2026-40075?

CVE-2026-40075 is a high-severity path traversal vulnerability in openmrs-core, published on 5 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

OpenMRS Core is an open source electronic medical record system platform. In versions 2.7.8 and earlier and versions 2.8.0 through 2.8.5, the `/openmrs/moduleResources/{moduleid}` endpoint is vulnerable to a path traversal attack. The ModuleResourcesServlet constructs a filesystem path from user-controlled input without performing path boundary validation — the getFile() method concatenates the user-supplied path into an absolute filesystem path without calling normalize() or checking that the result stays within the allowed module resources directory. Because this endpoint serves static resources required for rendering the login page, it is not protected by authentication filters, allowing unauthenticated exploitation.

An attacker can traverse directories and read arbitrary files from the server filesystem, including /etc/passwd and application configuration files containing database credentials. Successful exploitation requires the target deployment to run on Apache Tomcat versions prior to 8.5.31, where the ..; path parameter bypass is not mitigated by the container. Deployments on Tomcat 8.5.31 or later and Tomcat 9.0.10 or later are protected at the container level, though the underlying code defect remains. This issue has been fixed in versions after 2.7.8 (within the 2.7.x branch) and in version 2.8.6 and later.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-40075?

4 open source packages ship an affected version, including org.openmrs.web:openmrs-web. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.openmrs.web:openmrs-web` | Maven | All versions to 2.7.8 | None |
| `org.openmrs.web:openmrs-web` | Maven | All versions to 2.7.8 | None |
| `org.openmrs.web:openmrs-web` | Maven | From 2.8.0 | 2.8.6 |
| `org.openmrs.web:openmrs-web` | Maven | From 2.8.0 | 2.8.6 |

Products: Openmrs Openmrs.

## How do I fix CVE-2026-40075?

Upgrade org.openmrs.web:openmrs-web to 2.8.6 or later.

## Is CVE-2026-40075 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-40075 exists.

## Other vulnerabilities in openmrs-core

- [CVE-2018-19276](https://insights.sbomify.com/CVE-2018-19276/): Deserialization in n/a (critical 10.0)
- [CVE-2021-43094](https://insights.sbomify.com/CVE-2021-43094/): SQL injection in n/a (critical 9.8)
- [CVE-2017-12796](https://insights.sbomify.com/CVE-2017-12796/): Deserialization in n/a (critical 9.8)
- [CVE-2026-40076](https://insights.sbomify.com/CVE-2026-40076/): OpenMRS Core arbitrary file write and code execution via Zip Slip in module upload (critical 9.4)
- [CVE-2025-25928](https://insights.sbomify.com/CVE-2025-25928/): Cross-site request forgery in n/a (high 8.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-40075 and fix it if it is affected.

What it is: CVE-2026-40075 is a high-severity path traversal vulnerability in openmrs-core, published on 5 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-40075 exists.

Affected packages and fixed versions:
- org.openmrs.web:openmrs-web (Maven): affected all versions up to 2.7.8; no fix listed
- org.openmrs.web:openmrs-web (Maven): affected all versions up to 2.7.8; no fix listed
- org.openmrs.web:openmrs-web (Maven): affected from 2.8.0; fixed in 2.8.6
- org.openmrs.web:openmrs-web (Maven): affected from 2.8.0; fixed in 2.8.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-40075/ (Markdown: https://insights.sbomify.com/CVE-2026-40075/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-40075
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-40075
- OSV: https://osv.dev/vulnerability/CVE-2026-40075

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-40075/
Summaries are generated and may contain mistakes; the official description above is the record.
