# CVE-2026-40077: Beszel has an IDOR in hub API endpoints that read system ID from URL parameter

> Authenticated users can access system data for other users by guessing system IDs due to missing authorization checks in the hub API.

- **Severity:** Low 3.5 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Apr 2026
- **Updated:** 13 Apr 2026
- **Also known as:** GHSA-5f5r-95pg-xrpm, GO-2026-5141

## What is CVE-2026-40077?

CVE-2026-40077 is a low-severity missing authorization vulnerability in henrygd beszel, published on 9 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Beszel is a server monitoring platform. Prior to 0.18.7, some API endpoints in the Beszel hub accept a user-supplied system ID and proceed without further checks that the user should have access to that system. As a result, any authenticated user can access these routes for any system if they know the system's ID. System IDs are random 15 character alphanumeric strings, and are not exposed to all users. However, it is theoretically possible for an authenticated user to enumerate a valid system ID via web API. To use the containers endpoints, the user would also need to enumerate a container ID, which is 12 digit hexadecimal string. This vulnerability is fixed in 0.18.7.

Weakness: CWE-184 (Incomplete List of Disallowed Inputs)

## Which versions are affected by CVE-2026-40077?

3 open source packages ship an affected version, including github.com/henrygd/beszel. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/henrygd/beszel` | Go | All versions | 0.18.7 |
| `github.com/henrygd/beszel` | Go | All versions | 0.18.7 |
| `github.com/henrygd/beszel` | Go | All versions | 0.18.7 |

Products: Beszel Beszel.

## How do I fix CVE-2026-40077?

Upgrade github.com/henrygd/beszel to 0.18.7 or later.

## Is CVE-2026-40077 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-40077 exists.

## Other vulnerabilities in henrygd beszel

- [CVE-2026-27734](https://insights.sbomify.com/CVE-2026-27734/): Beszel Vulnerable to Docker API Path Traversal via Unsanitized Container ID (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-40077 and fix it if it is affected.

What it is: CVE-2026-40077 is a low-severity missing authorization vulnerability in henrygd beszel, published on 9 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-40077 exists.

Affected packages and fixed versions:
- github.com/henrygd/beszel (Go): affected all versions; fixed in 0.18.7
- github.com/henrygd/beszel (Go): affected all versions; fixed in 0.18.7
- github.com/henrygd/beszel (Go): affected all versions; fixed in 0.18.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-40077/ (Markdown: https://insights.sbomify.com/CVE-2026-40077/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-40077
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-40077
- OSV: https://osv.dev/vulnerability/CVE-2026-40077

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-40077/
Summaries are generated and may contain mistakes; the official description above is the record.
