# CVE-2026-40083: Cacti: SQL Injection in managers.php

> Attackers with SNMP agent management permissions can execute arbitrary SQL commands via unsanitized input in managers.php, potentially reading or modifying database contents.

- **Severity:** High 7.2 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Jun 2026
- **Updated:** 30 Jun 2026
- **Also known as:** DEBIAN-CVE-2026-40083, GHSA-j9jv-6xjq-9hhj, UBUNTU-CVE-2026-40083

## What is CVE-2026-40083?

CVE-2026-40083 is a high-severity SQL injection vulnerability in Cacti Cacti, published on 25 Jun 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Cacti is an open source performance and fault management framework. Versions 1.2.30 and prior have SQL Injection through unsanitized unserialize+implode in managers.php.  At line 756 of managers.php, the application assigns $selected_items by calling cacti_unserialize(stripslashes(gnrv('selected_graphs_array'))). The  cacti_unserialize() function calls unserialize() with allowed_classes set to false, which prevents object injection but still allows arbitrary string  arrays to be deserialized. Then, at lines 760 to 766, the deserialized array values are passed directly into db_execute('DELETE FROM snmpagent_managers  WHERE id IN (' . implode(',', $selected_items) . ')'), where they are imploded into the SQL statement without any integer validation, resulting in SQL  Injection when using SNMP agent management permissions. This issue has been fixed in version 1.2.31.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2026-40083?

It affects 1 product.


Products: Cacti Cacti.

## How do I fix CVE-2026-40083?

Upgrade to a fixed version.

## Is CVE-2026-40083 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-40083 exists.

Public exploit code:

- SQL Injection at Cacti (github_poc): https://github.com/hakaioffsec/CVE-2026-40083

## Other vulnerabilities in Cacti Cacti

- [CVE-2022-46169](https://insights.sbomify.com/CVE-2022-46169/): Cacti Command Injection (critical 9.8, exploited in the wild)
- [CVE-2026-39893](https://insights.sbomify.com/CVE-2026-39893/): Cacti: Pre-authentication SQL injection via rfilter RLIKE clause in graph_view.php (critical 9.8)
- [CVE-2026-39938](https://insights.sbomify.com/CVE-2026-39938/): Cacti: Unauthenticated RCE on Graph Image (critical 9.8)
- [CVE-2026-39955](https://insights.sbomify.com/CVE-2026-39955/): Cacti has Pre-Authentication SQL Injection via unanchored FILTER_VALIDATE_REGEXP in graph_view.php (critical 9.8)
- [CVE-2023-39361](https://insights.sbomify.com/CVE-2023-39361/): Unauthenticated SQL Injection in graph_view.php in Cacti (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-40083 and fix it if it is affected.

What it is: CVE-2026-40083 is a high-severity SQL injection vulnerability in Cacti Cacti, published on 25 Jun 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-40083 exists.

Affected product: Cacti Cacti. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-40083/ (Markdown: https://insights.sbomify.com/CVE-2026-40083/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-40083
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-40083
- OSV: https://osv.dev/vulnerability/CVE-2026-40083

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-40083/
Summaries are generated and may contain mistakes; the official description above is the record.
