# CVE-2026-40091: SpiceDB: SPICEDB_DATASTORE_CONN_URI is leaked on startup logs

> SpiceDB leaks datastore connection strings with plaintext passwords in startup logs, allowing attackers with log access to steal database credentials.

- **Severity:** Medium 6.0 (`CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Apr 2026
- **Updated:** 15 Apr 2026
- **Also known as:** GHSA-jf4f-rr2c-9m58, GO-2026-5465

## What is CVE-2026-40091?

CVE-2026-40091 is a medium-severity vulnerability in authzed spicedb, published on 14 Apr 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

SpiceDB is an open source database system for creating and managing security-critical application permissions. In versions 1.49.0 through 1.51.0, when SpiceDB starts with log level info, the startup "configuration" log will include the full datastore DSN, including the plaintext password, inside DatastoreConfig.URI. This issue has been fixed in version 1.51.1. If users are unable to immediately upgrade, they can work around this issue by changing the log level to warn or error.

Weakness: CWE-532 (Insertion of Sensitive Information into Log File)

## Which versions are affected by CVE-2026-40091?

3 open source packages ship an affected version, including github.com/authzed/spicedb. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/authzed/spicedb` | Go | From 1.49.0 | 1.51.1 |
| `github.com/authzed/spicedb` | Go | From 1.49.0 | 1.51.1 |
| `github.com/authzed/spicedb` | Go | From 1.49.0 | 1.51.1 |

Products: Authzed Spicedb.

## How do I fix CVE-2026-40091?

Upgrade github.com/authzed/spicedb to 1.51.1 or later.

## Is CVE-2026-40091 being exploited?

There is no known exploitation of CVE-2026-40091 in the wild and no public exploit code.

## Other vulnerabilities in authzed spicedb

- [CVE-2023-29193](https://insights.sbomify.com/CVE-2023-29193/): SpiceDB binding metrics port to untrusted networks and can leak command-line flags (high 8.7)
- [CVE-2022-21646](https://insights.sbomify.com/CVE-2022-21646/): Lookup operations do not take into account wildcards in SpiceDB (high 8.1)
- [CVE-2024-27101](https://insights.sbomify.com/CVE-2024-27101/): Integer overflow in chunking helper causes dispatching to miss elements or panic (high 7.3)
- [CVE-2023-46255](https://insights.sbomify.com/CVE-2023-46255/): `SPICEDB_DATASTORE_CONN_URI` is leaked when URI cannot be parsed (medium 4.2)
- [CVE-2025-49011](https://insights.sbomify.com/CVE-2025-49011/): SpiceDB checks involving relations with caveats can result in no permission when permission is expected (low 3.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-40091 and fix it if it is affected.

What it is: CVE-2026-40091 is a medium-severity vulnerability in authzed spicedb, published on 14 Apr 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-40091 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/authzed/spicedb (Go): affected from 1.49.0; fixed in 1.51.1
- github.com/authzed/spicedb (Go): affected from 1.49.0; fixed in 1.51.1
- github.com/authzed/spicedb (Go): affected from 1.49.0; fixed in 1.51.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-40091/ (Markdown: https://insights.sbomify.com/CVE-2026-40091/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-40091
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-40091
- OSV: https://osv.dev/vulnerability/CVE-2026-40091

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-40091/
Summaries are generated and may contain mistakes; the official description above is the record.
