CVE-2026-40097 Step CA affected by an index out of bounds panic in TPM attestation EKU validation

Low 3.7 Published Updated

An attacker can cause a denial of service in Step CA by sending a crafted TPM attestation certificate with an empty EKU extension, triggering a panic.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-40097?

CVE-2026-40097 is a low-severity denial of service vulnerability in smallstep certificates, published on 10 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Step CA is an online certificate authority for secure, automated certificate management for DevOps. From 0.24.0 to before 0.30.0-rc3, an attacker can trigger an index out-of-bounds panic in Step CA by sending a crafted attestation key (AK) certificate with an empty Extended Key Usage (EKU) extension during TPM device attestation. When processing a device-attest-01 ACME challenge using TPM attestation, Step CA validates that the AK certificate contains the tcg-kp-AIKCertificate Extended Key Usage OID. During this validation, the EKU extension value is decoded from its ASN.1 representation and the first element is checked. A crafted certificate could include an EKU extension that decodes to an empty sequence, causing the code to panic when accessing the first element of the empty slice. This vulnerability is only reachable when a device-attest-01 ACME challenge with TPM attestation is configured. Deployments not using TPM device attestation are not affected. This vulnerability is fixed in 0.30.0-rc3.

Weakness: CWE-129

Which versions are affected by CVE-2026-40097?

3 open source packages ship an affected version, including github.com/smallstep/certificates. It affects 1 product.

PackageAffectedFixed in
github.com/smallstep/certificates GoFrom 0.24.00.30.0
github.com/smallstep/certificates GoFrom 0.24.00.30.0
github.com/smallstep/certificates GoFrom 0.24.00.30.0

Products include Smallstep Step-Ca.

How do I fix CVE-2026-40097?

Upgrade github.com/smallstep/certificates to 0.30.0 or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2026-40097 being exploited?

There is no known exploitation of CVE-2026-40097 in the wild and no public exploit code.

Sources

Also known as CLEANSTART-2026-LF51380, CLEANSTART-2026-XI87503, GHSA-9qq8-cgcv-qmc9, GO-2026-5297, MINI-c5wr-7mfx-jwmr, MINI-j347-365p-qh3g.

Is CVE-2026-40097 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free