# CVE-2026-40098: OpenMage LTS: Cross-user wishlist import leads to private option & file disclosure

> Attackers can import other users' wishlist items into their cart using a valid sharing code, exposing private custom options and potentially allowing file disclosure.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Apr 2026
- **Updated:** 20 Apr 2026
- **Also known as:** GHSA-665x-ppc4-685w

## What is CVE-2026-40098?

CVE-2026-40098 is a medium-severity missing authorization vulnerability in OpenMage magento-lts, published on 20 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Magento Long Term Support (LTS) is an unofficial, community-driven project provides an alternative to the Magento Community Edition e-commerce platform with a high level of backward compatibility. Prior to version 20.17.0, the shared wishlist add-to-cart endpoint authorizes access with a public `sharing_code`, but loads the acted-on wishlist item by a separate global `wishlist_item_id` and never verifies that the item belongs to the shared wishlist referenced by that code. This lets an attacker use a valid shared wishlist code for wishlist A and a wishlist item ID belonging to victim wishlist B to import victim item B into the attacker's cart through the shared wishlist flow for wishlist A. Because the victim item's stored `buyRequest` is reused during cart import, the victim's private custom-option data is copied into the attacker's quote. If the product uses a file custom option, this can be elevated to cross-user file disclosure because the imported file metadata is preserved and the download endpoint is not ownership-bound. Version 20.17.0 patches the issue.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2026-40098?

2 open source packages ship an affected version, including openmage/magento-lts. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `openmage/magento-lts` | Packagist | All versions | 20.17.0 |
| `openmage/magento-lts` | Packagist | All versions | 20.17.0 |

Products: Openmage Magento.

## How do I fix CVE-2026-40098?

Upgrade openmage/magento-lts to 20.17.0 or later.

## Is CVE-2026-40098 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-40098 exists.

## Other vulnerabilities in OpenMage magento-lts

- [CVE-2021-21426](https://insights.sbomify.com/CVE-2021-21426/): Fixes a bug in Zend Framework's Stream HTTP Wrapper (critical 9.8)
- [CVE-2021-21427](https://insights.sbomify.com/CVE-2021-21427/): Backport for CVE-2021-21024 Blind SQLi from Magento 2 (critical 9.1)
- [CVE-2021-41144](https://insights.sbomify.com/CVE-2021-41144/): OpenMage LTS authenticated remote code execution through layout update (high 8.8)
- [CVE-2026-40488](https://insights.sbomify.com/CVE-2026-40488/): OpenMage LTS has Customer File Upload Extension Blocklist Bypass that Leads to Remote Code Execution (high 8.7)
- [CVE-2026-25524](https://insights.sbomify.com/CVE-2026-25524/): OpenMage LTS's Phar Deserialization leads to Remote Code Execution (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-40098 and fix it if it is affected.

What it is: CVE-2026-40098 is a medium-severity missing authorization vulnerability in OpenMage magento-lts, published on 20 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-40098 exists.

Affected packages and fixed versions:
- openmage/magento-lts (Packagist): affected all versions; fixed in 20.17.0
- openmage/magento-lts (Packagist): affected all versions; fixed in 20.17.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-40098/ (Markdown: https://insights.sbomify.com/CVE-2026-40098/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-40098
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-40098
- OSV: https://osv.dev/vulnerability/CVE-2026-40098

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-40098/
Summaries are generated and may contain mistakes; the official description above is the record.
