CVE-2026-40099 Kirby's page creation API bypasses the changeStatus permission check via unfiltered isDraft parameter
Authenticated users with page creation rights can bypass editorial workflow restrictions to immediately publish pages via the REST API.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-40099?
CVE-2026-40099 is a medium-severity missing authorization vulnerability in getkirby kirby, published on 24 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Kirby is an open-source content management system. Kirby's user permissions control which user role is allowed to perform specific actions to content models in the CMS. These permissions are defined for each role in the user blueprint (`site/blueprints/users/...`). It is also possible to customize the permissions for each target model in the model blueprints (such as in `site/blueprints/pages/...`) using the `options` feature. The permissions and options together control the authorization of user actions. For pages, Kirby provides the `pages.create` and `pages.changeStatus` permissions (among others). Prior to versions 4.9.0 and 5.4.0, Kirby checked these permissions independently and only for the respective action. However the `changeStatus` permission didn't take effect on page creation. New pages are created as drafts by default and need to be published by changing the page status of an existing page draft. This is ensured when the page is created via the Kirby Panel. However the REST API allows to override the `isDraft` flag when creating a new page. This allowed authenticated attackers with the `pages.create` permission to immediately create published pages, bypassing the normal editorial workflow. The problem has been patched in Kirby 4.9.0 and Kirby 5.4.0. Kirby has added a check to the page creation rules that ensures that users without the `pages.changeStatus` permission cannot create published pages, only page drafts.
Weakness: CWE-863
Which versions are affected by CVE-2026-40099?
4 open source packages ship an affected version, including getkirby/cms. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
getkirby/cms Packagist | All versions | 4.9.0 |
getkirby/cms Packagist | All versions | 4.9.0 |
getkirby/cms Packagist | From 5.0.0 | 5.4.0 |
getkirby/cms Packagist | From 5.0.0 | 5.4.0 |
Products include Getkirby Kirby.
How do I fix CVE-2026-40099?
Upgrade getkirby/cms to a fixed version for your release line: 4.9.0 or 5.4.0.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2026-40099 being exploited?
There is no known exploitation of CVE-2026-40099 in the wild and no public exploit code.
Other vulnerabilities in getkirby kirby
- CVE-2024-26483 Kirby vulnerable to unrestricted file upload of user avatar images
- CVE-2024-41964 Insufficient permission checks in the language settings in Kirby CMS
- CVE-2026-34587 Kirby has Server-Side Template Injection (SSTI) via double template resolution in option rendering
- CVE-2021-29460 Cross-site scripting (XSS) from unsanitized uploaded SVG files
- CVE-2023-38489 Kirby vulnerable to Insufficient Session Expiration after a password change
Sources
Also known as GHSA-w942-j9r6-hr6r.