# CVE-2026-40104: XWiki's REST APIs can list all pages/spaces, leading to unavailability

> Attackers can cause denial of service on large XWiki instances by triggering resource exhaustion via REST API endpoints that lack query limits.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Apr 2026
- **Updated:** 16 Apr 2026
- **Also known as:** GHSA-mrqg-xmgm-rc5g

## What is CVE-2026-40104?

CVE-2026-40104 is a medium-severity denial of service vulnerability in Xwiki Xwiki, published on 15 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

XWiki Platform is a generic wiki platform offering runtime services for applications built on top of it. Versions 1.8-rc-1, 17.0.0-rc-1 and 17.5.0-rc-1 and prior include a resource exhaustion vulnerability in REST API endpoints such as /xwiki/rest/wikis/xwiki/spaces/AnnotationCode/pages/AnnotationConfig/objects/AnnotationCode.AnnotationConfig/0/properties, which list all available pages as part of the metadata for database list properties without applying query limits. On large wikis, this can exhaust available server resources. This issue has been patched in versions 16.10.16, 17.4.8 and 17.10.1.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2026-40104?

12 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-legacy-oldcore and org.xwiki.platform:xwiki-platform-oldcore. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.xwiki.platform:xwiki-platform-legacy-oldcore` | Maven | From 1.8-rc-1 | 16.10.16 |
| `org.xwiki.platform:xwiki-platform-legacy-oldcore` | Maven | From 1.8-rc-1 | 16.10.16 |
| `org.xwiki.platform:xwiki-platform-legacy-oldcore` | Maven | From 17.0.0-rc-1 | 17.4.8 |
| `org.xwiki.platform:xwiki-platform-legacy-oldcore` | Maven | From 17.0.0-rc-1 | 17.4.8 |
| `org.xwiki.platform:xwiki-platform-legacy-oldcore` | Maven | From 17.5.0-rc-1 | 17.10.1 |
| `org.xwiki.platform:xwiki-platform-legacy-oldcore` | Maven | From 17.5.0-rc-1 | 17.10.1 |
| `org.xwiki.platform:xwiki-platform-oldcore` | Maven | From 1.8-rc-1 | 16.10.16 |
| `org.xwiki.platform:xwiki-platform-oldcore` | Maven | From 1.8-rc-1 | 16.10.16 |
| `org.xwiki.platform:xwiki-platform-oldcore` | Maven | From 17.0.0-rc-1 | 17.4.8 |
| `org.xwiki.platform:xwiki-platform-oldcore` | Maven | From 17.0.0-rc-1 | 17.4.8 |
| `org.xwiki.platform:xwiki-platform-oldcore` | Maven | From 17.5.0-rc-1 | 17.10.1 |
| `org.xwiki.platform:xwiki-platform-oldcore` | Maven | From 17.5.0-rc-1 | 17.10.1 |

Products: Xwiki Xwiki.

## How do I fix CVE-2026-40104?

Upgrade org.xwiki.platform:xwiki-platform-legacy-oldcore to a fixed version for your release line: 16.10.16, 17.4.8 or 17.10.1.

## Is CVE-2026-40104 being exploited?

There is no known exploitation of CVE-2026-40104 in the wild and no public exploit code.

## Other vulnerabilities in Xwiki Xwiki

- [CVE-2025-24893](https://insights.sbomify.com/CVE-2025-24893/): XWiki Platform Eval Injection (critical 9.8, exploited in the wild)
- [CVE-2025-53836](https://insights.sbomify.com/CVE-2025-53836/): XWiki Rendering is vulnerable to RCE attacks when processing nested macros (critical 10.0)
- [CVE-2024-55662](https://insights.sbomify.com/CVE-2024-55662/): XWiki allows remote code execution through the extension sheet (critical 10.0)
- [CVE-2024-55877](https://insights.sbomify.com/CVE-2024-55877/): XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList (critical 10.0)
- [CVE-2024-37901](https://insights.sbomify.com/CVE-2024-37901/): XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-40104 and fix it if it is affected.

What it is: CVE-2026-40104 is a medium-severity denial of service vulnerability in Xwiki Xwiki, published on 15 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-40104 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.xwiki.platform:xwiki-platform-legacy-oldcore (Maven): affected from 1.8-rc-1; fixed in 16.10.16
- org.xwiki.platform:xwiki-platform-legacy-oldcore (Maven): affected from 1.8-rc-1; fixed in 16.10.16
- org.xwiki.platform:xwiki-platform-legacy-oldcore (Maven): affected from 17.0.0-rc-1; fixed in 17.4.8
- org.xwiki.platform:xwiki-platform-legacy-oldcore (Maven): affected from 17.0.0-rc-1; fixed in 17.4.8
- org.xwiki.platform:xwiki-platform-legacy-oldcore (Maven): affected from 17.5.0-rc-1; fixed in 17.10.1
- org.xwiki.platform:xwiki-platform-legacy-oldcore (Maven): affected from 17.5.0-rc-1; fixed in 17.10.1
- org.xwiki.platform:xwiki-platform-oldcore (Maven): affected from 1.8-rc-1; fixed in 16.10.16
- org.xwiki.platform:xwiki-platform-oldcore (Maven): affected from 1.8-rc-1; fixed in 16.10.16
- org.xwiki.platform:xwiki-platform-oldcore (Maven): affected from 17.0.0-rc-1; fixed in 17.4.8
- org.xwiki.platform:xwiki-platform-oldcore (Maven): affected from 17.0.0-rc-1; fixed in 17.4.8
- org.xwiki.platform:xwiki-platform-oldcore (Maven): affected from 17.5.0-rc-1; fixed in 17.10.1
- org.xwiki.platform:xwiki-platform-oldcore (Maven): affected from 17.5.0-rc-1; fixed in 17.10.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-40104/ (Markdown: https://insights.sbomify.com/CVE-2026-40104/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-40104
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-40104
- OSV: https://osv.dev/vulnerability/CVE-2026-40104

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-40104/
Summaries are generated and may contain mistakes; the official description above is the record.
