# CVE-2026-40105: XWiki has Reflected Cross-Site Scripting (XSS) in its page history compare functionality

> Attackers can execute JavaScript in users' browsers via reflected XSS in page history comparison, potentially compromising admin accounts and the entire instance.

- **Severity:** Medium 6.5 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:H/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 15 Apr 2026
- **Updated:** 15 Apr 2026
- **Also known as:** GHSA-w4fj-87j5-f25c

## What is CVE-2026-40105?

CVE-2026-40105 is a medium-severity cross-site scripting vulnerability in Xwiki Xwiki, published on 15 Apr 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

XWiki Platform is a generic wiki platform offering runtime services for applications built on top of it. Versions 10.4-rc-1, through  16.10.15, 17.0.0-rc-1, through 17.4.7 and 17.5.0-rc-1 through 17.10.0 contain a reflected cross-site scripting vulnerability (XSS) in the comparison view between revisions of a page allows executing JavaScript code in the user's browser. If the current user is an admin, this can not only affect the current user but also the confidentiality, integrity and availability of the whole XWiki instance. If developers are unable to update immediately, they can apply the patch manually to templates/changesdoc.vm in the deployed WAR.

Weakness: CWE-80 (Improper Neutralization of Script-Related HTML Tags in a Web Page)

## Which versions are affected by CVE-2026-40105?

6 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-web-templates. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.xwiki.platform:xwiki-platform-web-templates` | Maven | From 10.4-rc-1 | 16.10.16 |
| `org.xwiki.platform:xwiki-platform-web-templates` | Maven | From 10.4-rc-1 | 16.10.16 |
| `org.xwiki.platform:xwiki-platform-web-templates` | Maven | From 17.0.0-rc-1 | 17.4.8 |
| `org.xwiki.platform:xwiki-platform-web-templates` | Maven | From 17.0.0-rc-1 | 17.4.8 |
| `org.xwiki.platform:xwiki-platform-web-templates` | Maven | From 17.5.0-rc-1 | 17.10.1 |
| `org.xwiki.platform:xwiki-platform-web-templates` | Maven | From 17.5.0-rc-1 | 17.10.1 |

Products: Xwiki Xwiki.

## How do I fix CVE-2026-40105?

Upgrade org.xwiki.platform:xwiki-platform-web-templates to a fixed version for your release line: 16.10.16, 17.4.8 or 17.10.1.

## Is CVE-2026-40105 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-40105 exists.

Public exploit code:

- XWiki - Cross-Site Scripting (nuclei): http/cves/2026/CVE-2026-40105.yaml

## Other vulnerabilities in Xwiki Xwiki

- [CVE-2025-24893](https://insights.sbomify.com/CVE-2025-24893/): XWiki Platform Eval Injection (critical 9.8, exploited in the wild)
- [CVE-2025-53836](https://insights.sbomify.com/CVE-2025-53836/): XWiki Rendering is vulnerable to RCE attacks when processing nested macros (critical 10.0)
- [CVE-2024-55662](https://insights.sbomify.com/CVE-2024-55662/): XWiki allows remote code execution through the extension sheet (critical 10.0)
- [CVE-2024-55877](https://insights.sbomify.com/CVE-2024-55877/): XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList (critical 10.0)
- [CVE-2024-37901](https://insights.sbomify.com/CVE-2024-37901/): XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-40105 and fix it if it is affected.

What it is: CVE-2026-40105 is a medium-severity cross-site scripting vulnerability in Xwiki Xwiki, published on 15 Apr 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-40105 exists.

Affected packages and fixed versions:
- org.xwiki.platform:xwiki-platform-web-templates (Maven): affected from 10.4-rc-1; fixed in 16.10.16
- org.xwiki.platform:xwiki-platform-web-templates (Maven): affected from 10.4-rc-1; fixed in 16.10.16
- org.xwiki.platform:xwiki-platform-web-templates (Maven): affected from 17.0.0-rc-1; fixed in 17.4.8
- org.xwiki.platform:xwiki-platform-web-templates (Maven): affected from 17.0.0-rc-1; fixed in 17.4.8
- org.xwiki.platform:xwiki-platform-web-templates (Maven): affected from 17.5.0-rc-1; fixed in 17.10.1
- org.xwiki.platform:xwiki-platform-web-templates (Maven): affected from 17.5.0-rc-1; fixed in 17.10.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-40105/ (Markdown: https://insights.sbomify.com/CVE-2026-40105/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-40105
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-40105
- OSV: https://osv.dev/vulnerability/CVE-2026-40105

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-40105/
Summaries are generated and may contain mistakes; the official description above is the record.
