CVE-2026-40108 GLPI Vulnerable to Stored XSS in ITIL Costs
Attackers can inject malicious scripts into ITIL costs, potentially executing code or hijacking user sessions in GLPI.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- None listed
What is CVE-2026-40108?
CVE-2026-40108 is a high-severity cross-site scripting vulnerability in glpi-project glpi, published on 2 Jun 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Official description
GLPI is a free asset and IT management software package. In versions 11.0.0 through 11.0.6, a technician can store an XSS payload in a ITIL costs. This issue has been fixed in version 11.0.7.
Weakness: CWE-79
Which versions are affected by CVE-2026-40108?
How do I fix CVE-2026-40108?
No fix has been published for CVE-2026-40108 yet. Limit exposure of the affected software until one is available.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2026-40108 being exploited?
There is no known exploitation of CVE-2026-40108 in the wild and no public exploit code.
Sources
Also known as GHSA-rhmv-j773-4gvh, UBUNTU-CVE-2026-40108.