# CVE-2026-40110: jupyter-server CORS origin validation bypass via unanchored regex in allow_origin_pat

> Attackers can bypass CORS restrictions in Jupyter Server by exploiting unanchored regex patterns, allowing cross-origin requests from malicious domains.

- **Severity:** High 7.6 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:H/VI:H/VA:L/SC:L/SI:L/SA:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 5 May 2026
- **Updated:** 22 Jul 2026
- **Also known as:** CLEANSTART-2026-HL28418, CLEANSTART-2026-QY94388, DEBIAN-CVE-2026-40110, GHSA-24qx-w28j-9m6p, PYSEC-2026-2187, UBUNTU-CVE-2026-40110

## What is CVE-2026-40110?

CVE-2026-40110 is a high-severity vulnerability in jupyter-server jupyter_server, published on 5 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Jupyter Server is the backend for Jupyter web applications. In versions 2.17.0 and earlier, the Origin header validation uses Python's re.match() to check incoming origins against the allow_origin_pat configuration value. Because re.match() only anchors at the start of the string and does not require a full match, a pattern intended to match only a trusted domain (e.g., trusted.example.com) will also match any origin that begins with that domain followed by additional characters (e.g., trusted.example.com.evil.com). An attacker who controls such a domain can bypass the CORS origin restriction and make cross-origin requests to the Jupyter Server API from an untrusted site. This issue has been fixed in version 2.18.0.

Weakness: CWE-625 (Permissive Regular Expression), CWE-777 (Regular Expression without Anchors)

## Which versions are affected by CVE-2026-40110?

3 open source packages ship an affected version, including jupyter-server. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `jupyter-server` | PyPI | All versions | 2.18.0 |
| `jupyter-server` | PyPI | All versions | 2.18.0 |
| `jupyter-server` | PyPI | All versions | 2.18.0 |

Products: Jupyter Jupyter Server.

## How do I fix CVE-2026-40110?

Upgrade jupyter-server to 2.18.0 or later.

## Is CVE-2026-40110 being exploited?

There is no known exploitation of CVE-2026-40110 in the wild and no public exploit code.

## Other vulnerabilities in jupyter-server jupyter_server

- [CVE-2026-44727](https://insights.sbomify.com/CVE-2026-44727/): Jupyter Server: Stored XSS in `NbconvertFileHandler` / `NbconvertPostHandler` via missing `sandbox` CSP (critical 9.3)
- [CVE-2026-35397](https://insights.sbomify.com/CVE-2026-35397/): jupyter-server path traversal allows access to sibling directories sharing root_dir name prefix (high 7.6)
- [CVE-2026-40934](https://insights.sbomify.com/CVE-2026-40934/): jupyter-server authentication cookies remain valid after password reset due to static cookie secret (high 7.6)
- [CVE-2024-35178](https://insights.sbomify.com/CVE-2024-35178/): Jupyter server on Windows discloses Windows user password hash (high 7.5)
- [CVE-2022-24757](https://insights.sbomify.com/CVE-2022-24757/): Sensitive Auth & Cookie data stored in Jupyter server logs (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-40110 and fix it if it is affected.

What it is: CVE-2026-40110 is a high-severity vulnerability in jupyter-server jupyter_server, published on 5 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-40110 in the wild and no public exploit code.

Affected packages and fixed versions:
- jupyter-server (PyPI): affected all versions; fixed in 2.18.0
- jupyter-server (PyPI): affected all versions; fixed in 2.18.0
- jupyter-server (PyPI): affected all versions; fixed in 2.18.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-40110/ (Markdown: https://insights.sbomify.com/CVE-2026-40110/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-40110
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-40110
- OSV: https://osv.dev/vulnerability/CVE-2026-40110

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-40110/
Summaries are generated and may contain mistakes; the official description above is the record.
