# CVE-2026-40111: PraisonAIAgents has an OS Command Injection via shell=True in Memory Hooks Executor (memory/hooks.py)

> Attackers can execute arbitrary OS commands via unsanitized input in memory hooks, potentially gaining full control of the host system.

- **Severity:** Critical 9.3 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Apr 2026
- **Updated:** 13 Apr 2026
- **Also known as:** GHSA-v7px-3835-7gjx, PYSEC-2026-487

## What is CVE-2026-40111?

CVE-2026-40111 is a critical command injection vulnerability in MervinPraison PraisonAIAgents, published on 9 Apr 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

PraisonAIAgents is a multi-agent teams system. Prior to 1.5.128, he memory hooks executor in praisonaiagents passes a user-controlled command string directly to subprocess.run() with shell=True at src/praisonai-agents/praisonaiagents/memory/hooks.py. No sanitization is performed and shell metacharacters are interpreted by /bin/sh before the intended command executes. Two independent attack surfaces exist. The first is via pre_run_command and post_run_command hook event types registered through the hooks configuration. The second and more severe surface is the .praisonai/hooks.json lifecycle configuration, where hooks registered for events such as BEFORE_TOOL and AFTER_TOOL fire automatically during agent operation. An agent that gains file-write access through prompt injection can overwrite .praisonai/hooks.json and have its payload execute silently at every subsequent lifecycle event without further user interaction. This vulnerability is fixed in 1.5.128.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2026-40111?

3 open source packages ship an affected version, including praisonaiagents. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `praisonaiagents` | PyPI | All versions | 1.5.128 |
| `praisonaiagents` | PyPI | All versions | 1.5.128 |
| `praisonaiagents` | PyPI | All versions | 1.5.128 |

Products: Praison Praisonaiagents.

## How do I fix CVE-2026-40111?

Upgrade praisonaiagents to 1.5.128 or later.

## Is CVE-2026-40111 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-40111 exists.

## Other vulnerabilities in MervinPraison PraisonAIAgents

- [CVE-2026-34938](https://insights.sbomify.com/CVE-2026-34938/): PraisonAI: Python Sandbox Escape via str Subclass startswith() Override in execute_code (critical 10.0)
- [CVE-2026-34954](https://insights.sbomify.com/CVE-2026-34954/): PraisonAI: SSRF in FileTools.download_file() via Unvalidated URL (high 8.6)
- [CVE-2026-34937](https://insights.sbomify.com/CVE-2026-34937/): PraisonAI: Shell Injection in run_python() via Unescaped $() Substitution (high 7.8)
- [CVE-2026-44335](https://insights.sbomify.com/CVE-2026-44335/): SSRF bypass in PraisonAI (high 7.7)
- [CVE-2026-40150](https://insights.sbomify.com/CVE-2026-40150/): PraisonAIAgents has SSRF and Local File Read via Unvalidated URLs in web_crawl Tool (high 7.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-40111 and fix it if it is affected.

What it is: CVE-2026-40111 is a critical command injection vulnerability in MervinPraison PraisonAIAgents, published on 9 Apr 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-40111 exists.

Affected packages and fixed versions:
- praisonaiagents (PyPI): affected all versions; fixed in 1.5.128
- praisonaiagents (PyPI): affected all versions; fixed in 1.5.128
- praisonaiagents (PyPI): affected all versions; fixed in 1.5.128

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-40111/ (Markdown: https://insights.sbomify.com/CVE-2026-40111/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-40111
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-40111
- OSV: https://osv.dev/vulnerability/CVE-2026-40111

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-40111/
Summaries are generated and may contain mistakes; the official description above is the record.
