# CVE-2026-40113: PraisonAI has an Argument Injection into Cloud Run Environment Variables via Unsanitized Comma in gcloud --set-env-vars

> Attackers can inject arbitrary environment variables into Cloud Run deployments via unsanitized commas in PraisonAI, potentially leading to code execution or privilege escalation.

- **Severity:** High 8.4 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Apr 2026
- **Updated:** 10 Apr 2026
- **Also known as:** GHSA-fvxx-ggmx-3cjg, PYSEC-2026-2913

## What is CVE-2026-40113?

CVE-2026-40113 is a high-severity command injection vulnerability in MervinPraison PraisonAI, published on 9 Apr 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

PraisonAI is a multi-agent teams system. Prior to 4.5.128, deploy.py constructs a single comma-delimited string for the gcloud run
deploy --set-env-vars argument by directly interpolating openai_model, openai_key, and openai_base without validating that these values do not contain commas. gcloud uses a comma as the key-value pair separator for --set-env-vars. A comma in any of the three values causes gcloud to parse the trailing text as additional KEY=VALUE definitions, injecting arbitrary environment variables into the deployed Cloud Run service. This vulnerability is fixed in 4.5.128.

Weakness: CWE-88 (Improper Neutralization of Argument Delimiters in a Command)

## Which versions are affected by CVE-2026-40113?

3 open source packages ship an affected version, including praisonai and PraisonAI. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `praisonai` | PyPI | All versions | 4.5.128 |
| `praisonai` | PyPI | All versions | 4.5.128 |
| `PraisonAI` | PyPI | All versions | 4.5.128 |

Products: Praison Praisonai.

## How do I fix CVE-2026-40113?

Upgrade praisonai to 4.5.128 or later.

## Is CVE-2026-40113 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-40113 exists.

## Other vulnerabilities in MervinPraison PraisonAI

- [CVE-2026-39888](https://insights.sbomify.com/CVE-2026-39888/): PraisonAIAgents has a sandbox escape via exception frame traversal in `execute_code` (subprocess mode) (critical 10.0)
- [CVE-2026-41497](https://insights.sbomify.com/CVE-2026-41497/): Incomplete fix for CVE-2026-34935: Command Injection in MervinPraison/PraisonAI (critical 9.8)
- [CVE-2026-40288](https://insights.sbomify.com/CVE-2026-40288/): PraisonAI: Critical RCE via `type: job` workflow YAML (critical 9.8)
- [CVE-2026-39890](https://insights.sbomify.com/CVE-2026-39890/): PraisonAI Affected by Remote Code Execution via YAML Deserialization in Agent Definition Loading (critical 9.8)
- [CVE-2026-34934](https://insights.sbomify.com/CVE-2026-34934/): PraisonAI: Second-Order SQL Injection in `get_all_user_threads` (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-40113 and fix it if it is affected.

What it is: CVE-2026-40113 is a high-severity command injection vulnerability in MervinPraison PraisonAI, published on 9 Apr 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-40113 exists.

Affected packages and fixed versions:
- praisonai (PyPI): affected all versions; fixed in 4.5.128
- praisonai (PyPI): affected all versions; fixed in 4.5.128
- PraisonAI (PyPI): affected all versions; fixed in 4.5.128

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-40113/ (Markdown: https://insights.sbomify.com/CVE-2026-40113/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-40113
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-40113
- OSV: https://osv.dev/vulnerability/CVE-2026-40113

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-40113/
Summaries are generated and may contain mistakes; the official description above is the record.
