# CVE-2026-40153: PraisonAIAgents: Environment Variable Secret Exfiltration via os.path.expandvars() Bypassing shell=False in Shell Tool

> Attackers can exfiltrate environment variable secrets and bypass approval checks in PraisonAIAgents by exploiting unsafe variable expansion in shell commands.

- **Severity:** High 7.4 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 9 Apr 2026
- **Updated:** 13 Apr 2026
- **Also known as:** GHSA-v8g7-9q6v-p3x8, PYSEC-2026-2953

## What is CVE-2026-40153?

CVE-2026-40153 is a high-severity vulnerability in MervinPraison PraisonAIAgents, published on 9 Apr 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

PraisonAIAgents is a multi-agent teams system. Prior to 1.5.128, the execute_command function in shell_tools.py calls os.path.expandvars() on every command argument at line 64, manually re-implementing shell-level environment variable expansion despite using shell=False (line 88) for security. This allows exfiltration of secrets stored in environment variables (database credentials, API keys, cloud access keys). The approval system displays the unexpanded $VAR references to human reviewers, creating a deceptive approval where the displayed command differs from what actually executes. This vulnerability is fixed in 1.5.128.

Weakness: CWE-526 (Cleartext Storage of Sensitive Information in an Environment Variable)

## Which versions are affected by CVE-2026-40153?

3 open source packages ship an affected version, including praisonaiagents. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `praisonaiagents` | PyPI | All versions | 1.5.128 |
| `praisonaiagents` | PyPI | All versions | 1.5.128 |
| `praisonaiagents` | PyPI | All versions | 1.5.128 |

Products: Praison Praisonaiagents.

## How do I fix CVE-2026-40153?

Upgrade praisonaiagents to 1.5.128 or later.

## Is CVE-2026-40153 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-40153 exists.

## Other vulnerabilities in MervinPraison PraisonAIAgents

- [CVE-2026-34938](https://insights.sbomify.com/CVE-2026-34938/): PraisonAI: Python Sandbox Escape via str Subclass startswith() Override in execute_code (critical 10.0)
- [CVE-2026-40111](https://insights.sbomify.com/CVE-2026-40111/): PraisonAIAgents has an OS Command Injection via shell=True in Memory Hooks Executor (memory/hooks.py) (critical 9.3)
- [CVE-2026-34954](https://insights.sbomify.com/CVE-2026-34954/): PraisonAI: SSRF in FileTools.download_file() via Unvalidated URL (high 8.6)
- [CVE-2026-34937](https://insights.sbomify.com/CVE-2026-34937/): PraisonAI: Shell Injection in run_python() via Unescaped $() Substitution (high 7.8)
- [CVE-2026-44335](https://insights.sbomify.com/CVE-2026-44335/): SSRF bypass in PraisonAI (high 7.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-40153 and fix it if it is affected.

What it is: CVE-2026-40153 is a high-severity vulnerability in MervinPraison PraisonAIAgents, published on 9 Apr 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-40153 exists.

Affected packages and fixed versions:
- praisonaiagents (PyPI): affected all versions; fixed in 1.5.128
- praisonaiagents (PyPI): affected all versions; fixed in 1.5.128
- praisonaiagents (PyPI): affected all versions; fixed in 1.5.128

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-40153/ (Markdown: https://insights.sbomify.com/CVE-2026-40153/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-40153
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-40153
- OSV: https://osv.dev/vulnerability/CVE-2026-40153

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-40153/
Summaries are generated and may contain mistakes; the official description above is the record.
