CVE-2026-40155 Auth0 Next.js SDK has Improper Proxy Cache Lookup
Simultaneous requests with DPoP enabled may cause improper proxy cache lookups, potentially bypassing authentication checks in Next.js applications.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2026-40155?
CVE-2026-40155 is a medium-severity vulnerability in nextjs-auth0, published on 17 Apr 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
The Auth0 Next.js SDK is a library for implementing user authentication in Next.js applications. In versions 4.12.0 through 4.17.1, simultaneous requests that trigger a nonce retry may cause the proxy cache fetcher to perform improper lookups for the token request results. Users are affected if their project uses both the vulnerable versions and the proxy handler /me/* and /my-org/* with DPoP enabled. This issue has been fixed in version 4.18.0.
Which versions are affected by CVE-2026-40155?
2 open source packages ship an affected version, including @auth0/nextjs-auth0. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
@auth0/nextjs-auth0 npm | From 4.12.0 | 4.18.0 |
@auth0/nextjs-auth0 npm | From 4.12.0 | 4.18.0 |
Products include Auth0 Nextjs-Auth0.
How do I fix CVE-2026-40155?
Upgrade @auth0/nextjs-auth0 to 4.18.0 or later.
Is CVE-2026-40155 being exploited?
There is no known exploitation of CVE-2026-40155 in the wild and no public exploit code.
Other vulnerabilities in nextjs-auth0
Sources
Also known as GHSA-xq8m-7c5p-c2r6.