{"answers":{"affected":"2 open source packages ship an affected version, including @auth0/nextjs-auth0. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-40155 in the wild and no public exploit code.","fix":"Upgrade @auth0/nextjs-auth0 to 4.18.0 or later.","what":"CVE-2026-40155 is a medium-severity vulnerability in nextjs-auth0, published on 17 Apr 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-40155 and fix it if it is affected.\n\nWhat it is: CVE-2026-40155 is a medium-severity vulnerability in nextjs-auth0, published on 17 Apr 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2026-40155 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- @auth0/nextjs-auth0 (npm): affected from 4.12.0; fixed in 4.18.0\n- @auth0/nextjs-auth0 (npm): affected from 4.12.0; fixed in 4.18.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-40155/ (Markdown: https://insights.sbomify.com/CVE-2026-40155/index.md)","id":"CVE-2026-40155","markdown":"https://insights.sbomify.com/CVE-2026-40155/index.md","name":"CVE-2026-40155","record":{"aliases":["GHSA-xq8m-7c5p-c2r6"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"Auth0 Next.js SDK","requires_auth":"low_privilege","summary":"Simultaneous requests with DPoP enabled may cause improper proxy cache lookups, potentially bypassing authentication checks in Next.js applications.","user_interaction":"required","vuln_class":"race_condition"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"nextjs-auth0","vendor":"auth0"}],"cvss":{"score":5.4,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:H/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-863","name":"Incorrect Authorization"},{"id":"CWE-362","name":"Concurrent Execution using Shared Resource with Improper Synchronization"}],"description":"The Auth0 Next.js SDK is a library for implementing user authentication in Next.js applications. In versions 4.12.0 through 4.17.1, simultaneous requests that trigger a nonce retry may cause the proxy cache fetcher to perform improper lookups for the token request results. Users are affected if their project uses both the vulnerable versions and the proxy handler /me/* and /my-org/* with DPoP enabled. This issue has been fixed in version 4.18.0.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Auth0 Next.js SDK has Improper Proxy Cache Lookup","id":"CVE-2026-40155","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"race_condition","year":"2026"},"n_packages":2,"n_references":3,"next":{"headline":"PraisonAI Affected by Implicit Execution of Arbitrary Code via Automatic `tools.py` Loading","id":"CVE-2026-40156"},"packages":[{"ecosystem":"npm","fixed":["4.18.0"],"introduced":["4.12.0"],"last_affected":[],"package":"@auth0/nextjs-auth0","purl":null,"source":"GHSA-xq8m-7c5p-c2r6"},{"ecosystem":"npm","fixed":["4.18.0"],"introduced":["4.12.0"],"last_affected":[],"package":"@auth0/nextjs-auth0","purl":"pkg:npm/%40auth0/nextjs-auth0","source":"GHSA-xq8m-7c5p-c2r6"}],"prev":{"headline":"PraisonAI Affected by Untrusted Remote Template Code Execution","id":"CVE-2026-40154"},"products":["nextjs-auth0"],"published":"2026-04-17","related":[{"cvss_score":8,"headline":"Reflected XSS from the callback handler's error query parameter","id":"CVE-2021-32702","kev_date_added":null,"published":"2021-06-25"},{"cvss_score":6.4,"headline":"Open redirect in nextjs-auth0","id":"CVE-2021-43812","kev_date_added":null,"published":"2021-12-16"},{"cvss_score":5.7,"headline":"Auth0 Next.js SDK has Improper Validation of Query Parameters","id":"CVE-2025-67716","kev_date_added":null,"published":"2025-12-11"},{"cvss_score":5.4,"headline":"Auth0 Next.js SDK has Improper Request Caching Lookup","id":"CVE-2025-67490","kev_date_added":null,"published":"2025-12-10"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-04-20","vendors":["auth0"]},"summary":"Simultaneous requests with DPoP enabled may cause improper proxy cache lookups, potentially bypassing authentication checks in Next.js applications.","url":"https://insights.sbomify.com/CVE-2026-40155/"}