# CVE-2026-40156: PraisonAI Affected by Implicit Execution of Arbitrary Code via Automatic `tools.py` Loading

> Attackers can execute arbitrary code by placing a malicious tools.py file in the working directory, affecting users running PraisonAI.

- **Severity:** High 7.8 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 10 Apr 2026
- **Updated:** 13 Apr 2026
- **Also known as:** GHSA-2g3w-cpc4-chr4, PYSEC-2026-2895

## What is CVE-2026-40156?

CVE-2026-40156 is a high-severity code injection vulnerability in MervinPraison PraisonAI, published on 10 Apr 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

PraisonAI is a multi-agent teams system. Prior to 4.5.128, PraisonAI automatically loads a file named tools.py from the current working directory to discover and register custom agent tools. This loading process uses importlib.util.spec_from_file_location and immediately executes module-level code via spec.loader.exec_module() without explicit user consent, validation, or sandboxing. The tools.py file is loaded implicitly, even when it is not referenced in configuration files or explicitly requested by the user. As a result, merely placing a file named tools.py in the working directory is sufficient to trigger code execution. This behavior violates the expected security boundary between user-controlled project files (e.g., YAML configurations) and executable code, as untrusted content in the working directory is treated as trusted and executed automatically. If an attacker can place a malicious tools.py file into a directory where a user or automated system (e.g., CI/CD pipeline) runs praisonai, arbitrary code execution occurs immediately upon startup, before any agent logic begins.  This vulnerability is fixed in 4.5.128.

Weakness: CWE-94 (Improper Control of Generation of Code), CWE-829 (Inclusion of Functionality from Untrusted Control Sphere), CWE-426 (Untrusted Search Path)

## Which versions are affected by CVE-2026-40156?

3 open source packages ship an affected version, including praisonai. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `praisonai` | PyPI | All versions | 4.5.128 |
| `praisonai` | PyPI | All versions | 4.5.128 |
| `praisonai` | PyPI | All versions | 4.5.128 |

Products: Praison Praisonai.

## How do I fix CVE-2026-40156?

Upgrade praisonai to 4.5.128 or later.

## Is CVE-2026-40156 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-40156 exists.

## Other vulnerabilities in MervinPraison PraisonAI

- [CVE-2026-39888](https://insights.sbomify.com/CVE-2026-39888/): PraisonAIAgents has a sandbox escape via exception frame traversal in `execute_code` (subprocess mode) (critical 10.0)
- [CVE-2026-41497](https://insights.sbomify.com/CVE-2026-41497/): Incomplete fix for CVE-2026-34935: Command Injection in MervinPraison/PraisonAI (critical 9.8)
- [CVE-2026-40288](https://insights.sbomify.com/CVE-2026-40288/): PraisonAI: Critical RCE via `type: job` workflow YAML (critical 9.8)
- [CVE-2026-39890](https://insights.sbomify.com/CVE-2026-39890/): PraisonAI Affected by Remote Code Execution via YAML Deserialization in Agent Definition Loading (critical 9.8)
- [CVE-2026-34934](https://insights.sbomify.com/CVE-2026-34934/): PraisonAI: Second-Order SQL Injection in `get_all_user_threads` (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-40156 and fix it if it is affected.

What it is: CVE-2026-40156 is a high-severity code injection vulnerability in MervinPraison PraisonAI, published on 10 Apr 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-40156 exists.

Affected packages and fixed versions:
- praisonai (PyPI): affected all versions; fixed in 4.5.128
- praisonai (PyPI): affected all versions; fixed in 4.5.128
- praisonai (PyPI): affected all versions; fixed in 4.5.128

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-40156/ (Markdown: https://insights.sbomify.com/CVE-2026-40156/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-40156
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-40156
- OSV: https://osv.dev/vulnerability/CVE-2026-40156

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-40156/
Summaries are generated and may contain mistakes; the official description above is the record.
