# CVE-2026-40158: PraisonAI has Improper Control of Generation of Code ('Code Injection') and Protection Mechanism Failure in praisonai

> Attackers can bypass the Python sandbox to execute arbitrary code when running untrusted agent code in PraisonAI.

- **Severity:** High 8.6 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 10 Apr 2026
- **Updated:** 10 Apr 2026
- **Also known as:** GHSA-3c4r-6p77-xwr7, PYSEC-2026-2898

## What is CVE-2026-40158?

CVE-2026-40158 is a high-severity code injection vulnerability in MervinPraison PraisonAI, published on 10 Apr 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

PraisonAI is a multi-agent teams system. Prior to 4.5.128, PraisonAI's AST-based Python sandbox can be bypassed using type.__getattribute__ trampoline, allowing arbitrary code execution when running untrusted agent code. The _execute_code_direct function in praisonaiagents/tools/python_tools.py uses AST filtering to block dangerous Python attributes like __subclasses__, __globals__, and __bases__. However, the filter only checks ast.Attribute nodes, allowing a bypass. The sandbox relies on AST-based filtering of attribute access but fails to account for dynamic attribute resolution via built-in methods such as type.getattribute, resulting in incomplete enforcement of security restrictions. The string '__subclasses__' is an ast.Constant, not an ast.Attribute, so it is never checked against the blocked list. This vulnerability is fixed in 4.5.128.

Weakness: CWE-94 (Improper Control of Generation of Code), CWE-693 (Protection Mechanism Failure)

## Which versions are affected by CVE-2026-40158?

3 open source packages ship an affected version, including praisonai and PraisonAI. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `praisonai` | PyPI | All versions | 4.5.128 |
| `praisonai` | PyPI | All versions | 4.5.128 |
| `PraisonAI` | PyPI | All versions | 4.5.128 |

Products: Praison Praisonai.

## How do I fix CVE-2026-40158?

Upgrade praisonai to 4.5.128 or later.

## Is CVE-2026-40158 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-40158 exists.

## Other vulnerabilities in MervinPraison PraisonAI

- [CVE-2026-39888](https://insights.sbomify.com/CVE-2026-39888/): PraisonAIAgents has a sandbox escape via exception frame traversal in `execute_code` (subprocess mode) (critical 10.0)
- [CVE-2026-41497](https://insights.sbomify.com/CVE-2026-41497/): Incomplete fix for CVE-2026-34935: Command Injection in MervinPraison/PraisonAI (critical 9.8)
- [CVE-2026-40288](https://insights.sbomify.com/CVE-2026-40288/): PraisonAI: Critical RCE via `type: job` workflow YAML (critical 9.8)
- [CVE-2026-39890](https://insights.sbomify.com/CVE-2026-39890/): PraisonAI Affected by Remote Code Execution via YAML Deserialization in Agent Definition Loading (critical 9.8)
- [CVE-2026-34934](https://insights.sbomify.com/CVE-2026-34934/): PraisonAI: Second-Order SQL Injection in `get_all_user_threads` (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-40158 and fix it if it is affected.

What it is: CVE-2026-40158 is a high-severity code injection vulnerability in MervinPraison PraisonAI, published on 10 Apr 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-40158 exists.

Affected packages and fixed versions:
- praisonai (PyPI): affected all versions; fixed in 4.5.128
- praisonai (PyPI): affected all versions; fixed in 4.5.128
- PraisonAI (PyPI): affected all versions; fixed in 4.5.128

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-40158/ (Markdown: https://insights.sbomify.com/CVE-2026-40158/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-40158
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-40158
- OSV: https://osv.dev/vulnerability/CVE-2026-40158

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-40158/
Summaries are generated and may contain mistakes; the official description above is the record.
