# CVE-2026-40159: PraisonAI Exposes Sensitive Environment Variable via Untrusted MCP Subprocess Execution

> PraisonAI exposes sensitive environment variables to untrusted subprocesses, allowing attackers to steal API keys and credentials via malicious MCP commands.

- **Severity:** Medium 5.5 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 10 Apr 2026
- **Updated:** 15 Apr 2026
- **Also known as:** GHSA-pj2r-f9mw-vrcq, PYSEC-2026-2918

## What is CVE-2026-40159?

CVE-2026-40159 is a medium-severity vulnerability in MervinPraison PraisonAI, published on 10 Apr 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

PraisonAI is a multi-agent teams system. Prior to 4.5.128, PraisonAI’s MCP (Model Context Protocol) integration allows spawning background servers via stdio using user-supplied command strings (e.g., MCP("npx -y @smithery/cli ...")). These commands are executed through Python’s subprocess module. By default, the implementation forwards the entire parent process environment to the spawned subprocess. As a result, any MCP command executed in this manner inherits all environment variables from the host process, including sensitive data such as API keys, authentication tokens, and database credentials. This behavior introduces a security risk when untrusted or third-party commands are used. In common scenarios where MCP tools are invoked via package runners such as npx -y, arbitrary code from external or potentially compromised packages may execute with access to these inherited environment variables. This creates a risk of unintended credential exposure and enables potential supply chain attacks through silent exfiltration of secrets. This vulnerability is fixed in 4.5.128.

Weakness: CWE-214 (Invocation of Process Using Visible Sensitive Information), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-40159?

3 open source packages ship an affected version, including praisonai and PraisonAI. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `praisonai` | PyPI | All versions | 4.5.128 |
| `praisonai` | PyPI | All versions | 4.5.128 |
| `PraisonAI` | PyPI | All versions | 4.5.128 |

Products: Praison Praisonai.

## How do I fix CVE-2026-40159?

Upgrade praisonai to 4.5.128 or later.

## Is CVE-2026-40159 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-40159 exists.

## Other vulnerabilities in MervinPraison PraisonAI

- [CVE-2026-39888](https://insights.sbomify.com/CVE-2026-39888/): PraisonAIAgents has a sandbox escape via exception frame traversal in `execute_code` (subprocess mode) (critical 10.0)
- [CVE-2026-41497](https://insights.sbomify.com/CVE-2026-41497/): Incomplete fix for CVE-2026-34935: Command Injection in MervinPraison/PraisonAI (critical 9.8)
- [CVE-2026-40288](https://insights.sbomify.com/CVE-2026-40288/): PraisonAI: Critical RCE via `type: job` workflow YAML (critical 9.8)
- [CVE-2026-39890](https://insights.sbomify.com/CVE-2026-39890/): PraisonAI Affected by Remote Code Execution via YAML Deserialization in Agent Definition Loading (critical 9.8)
- [CVE-2026-34934](https://insights.sbomify.com/CVE-2026-34934/): PraisonAI: Second-Order SQL Injection in `get_all_user_threads` (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-40159 and fix it if it is affected.

What it is: CVE-2026-40159 is a medium-severity vulnerability in MervinPraison PraisonAI, published on 10 Apr 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-40159 exists.

Affected packages and fixed versions:
- praisonai (PyPI): affected all versions; fixed in 4.5.128
- praisonai (PyPI): affected all versions; fixed in 4.5.128
- PraisonAI (PyPI): affected all versions; fixed in 4.5.128

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-40159/ (Markdown: https://insights.sbomify.com/CVE-2026-40159/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-40159
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-40159
- OSV: https://osv.dev/vulnerability/CVE-2026-40159

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-40159/
Summaries are generated and may contain mistakes; the official description above is the record.
